Premiere Pro 2.0 Question

Discussion and help related to Adobe video software goes here. e.x. Premiere, After Effects, Photoshop, etc.

Premiere Pro 2.0 Question

Postby Dengen » Tue Nov 14, 2006 3:04 am

Having a problem with Adobe Premiere Pro 2.0

When I try to Import an AVI into the project such as one encoded with Divx or Xvid I get an error reading "Unsupported Audio Rate in File". I went to a few sites and even did a search here but can't seem to get a striaght answer on how to fix it or get around it.

One site mentioned it was a confliction problem with another program. I followed the steps, but still no luck.

I'm mostly looking for a simple solution. Not a very long drawn out re-code everything into new files with 3 different programs solution.
Dengen
 
Joined: 26 Jul 2006

Postby Dengen » Tue Nov 14, 2006 4:07 am

Nevermind. I was able to find a quick fix for it.

Basically the videos I'm using were Divx. So what I did to skate around the problem was configure the Divx Codec to NOT Support decoding of Generic MPEG-4 video. Now I can import to Premiere Pro. However the videos are very choppy, but I can still get clips from it fine. After I get the clips I simply render the work area then it runs perfect.

Just used the DivX Playback Config Utility to switch it on and off as needed. When I want to edit, I can just turn it off, and when I want to watch me shows, I can just turn it on.

I haven't tried to render and export like this yet but I'm sure it will be fine.
I know it seems to be a really generic way of doing it, but its working for me.
Dengen
 
Joined: 26 Jul 2006

Postby Gepetto » Tue Nov 14, 2006 5:10 am

If you ummarked "Generic MPEG-4" then your video is NOT DivX, but XviD, which is also an mpeg-4 codec. DivX was trying to decode it and probably another codec (like XviD or ffdshow) was trying the same thing. Hence, it didn't work.

IF the problem is with an audio stream, which is your case, the correct way to fix it would be removing the audio stream, either via the KILLAUDIO() command in AviSynth of by creating a new AVI in vdub without the audio stream.

However, the footage is still choppy, as you said yourself. The solution:

Image

These files are not accurate because of the lossy encoding. Convert them to a lossless codec.

"How do I do that?", you ask?

Look no further.

Here's how you do it:

1: open the MKV/OGM in virtualdubmod,
2: go to the "streams" tab, deactivate all audio,
3: then go to the "video" tab and select "Direct Stream Copy"
4: now File>Save As... and save as an AVI.

You'll have the video with no audio in AVI. If the file doesn't open in VDM, load it through a directshowsource AVS with the killaudio() command.

IF IT STILL DOESN'T WORK, you need to convert to lossless:
1: Download HuffYUV.
2: Open VirtualDubMod again, deactivate the audio, but this time select "Fast Recompress" on the video tab.
3: Video>Compression, select HuffYUV.
4: File>Save As...

Done. You have a huge lossless AVI file. If it's too big, then save clips rather than entire episodes.


If your method worked, then it's perfectly fine, but for future reference, or in case a similar problem comes up that can't be fixed by your method, this is the right way to do it.

--Gepetto
And God spoke unto the Chicken, and He said: "Thou shalt crosseth the road", and the Chicken did cross the road, and there was much rejoicing.
My DeviantART profile
User avatar
Gepetto
Mr. Poopy Pants
 
Joined: 10 Jun 2004
Location: The Tokyo Settlement
Status: Bored to tears

Postby Dengen » Tue Nov 14, 2006 6:07 am

Ahh thank you. I'm gonna try the virtualdubmod method out.

The trick I used is working, but the only thing is I think I may be able to get better quality trying to convert them with no audio like you said.

I made a quick seq. and then exported it to a WMV and it dosen't seem to be as good of quality as the last one I made. However, the file is larger and I have forgotten exactly what settings I need since its been a while. May just be a matter of memory. Thanks for the info.
Dengen
 
Joined: 26 Jul 2006

Postby Gepetto » Tue Nov 14, 2006 8:50 am

You're welcome. If you want to improve the quality, some pre-processing via AviSynth will do wonders. Read this page if you're interrested:

http://www.animemusicvideos.org/guides/ ... tqual.html

--Gepetto
And God spoke unto the Chicken, and He said: "Thou shalt crosseth the road", and the Chicken did cross the road, and there was much rejoicing.
My DeviantART profile
User avatar
Gepetto
Mr. Poopy Pants
 
Joined: 10 Jun 2004
Location: The Tokyo Settlement
Status: Bored to tears

Postby Scintilla » Tue Nov 14, 2006 6:07 pm

Gepetto wrote:Image

Fool! You don't use the giant flashing banner without also including a link to <a href="http://www.amvwiki.org/index.php/DivX_Editing">the informative page that tells you why and how</a>! :P


(But thank you for not using my bandwidth, not that I really mind in this case...)
ImageImage
:pizza: :pizza: Image :pizza: :pizza:
User avatar
Scintilla
(for EXTREME)
 
Joined: 31 Mar 2003
Location: New Jersey
Status: Quo

Postby Dengen » Wed Nov 15, 2006 10:05 am

I exported the first part of my movie using all clips from the Virtualdubmod method and it does seem to be a better quality. I only changed a few small options and its working great. I haven't tried the pre-processing using AviSynth, but maybe I'll give it a go and see how it is.
Dengen
 
Joined: 26 Jul 2006

Postby Gepetto » Thu Nov 16, 2006 5:34 am

Scintilla wrote:Fool! You don't use the giant flashing banner without also including a link to <a href="http://www.amvwiki.org/index.php/DivX_Editing">the informative page that tells you why and how</a>! :P


I knew I had forgotten something...

Scintilla wrote:(But thank you for not using my bandwidth, not that I really mind in this case...)


I prefer uploading to my own account at photobucket so if other people's servers shut down my links aren't screwed up (of course, if photobucket shuts down...)

Dengen wrote:I haven't tried the pre-processing using AviSynth, but maybe I'll give it a go and see how it is.


Do try. It's a wonderful tool.
And God spoke unto the Chicken, and He said: "Thou shalt crosseth the road", and the Chicken did cross the road, and there was much rejoicing.
My DeviantART profile
User avatar
Gepetto
Mr. Poopy Pants
 
Joined: 10 Jun 2004
Location: The Tokyo Settlement
Status: Bored to tears


Return to Adobe Software

Who is online

Users browsing this forum: No registered users and 0 guests

cron