File problem with FCE ("codec could not be opened")

For discussion on Mac software and video editing on Mac computers.

File problem with FCE ("codec could not be opened")

Postby Yolko » Mon Jul 02, 2012 2:03 pm

To start off, I deeply apologize if this problem has been discussed and solved in some other topic, at least I didn't find it. Aaand sorry if this is in the wrong place too.

But anyway, here's my problem. I use Final Cut Express 4.0.1. I haven't been editing for a year now, but now that I got the inspiration and time again, I run into some techical troubles. I took the same footage files I have used in a project before, .mkv files processed with avidemux with this guide. Buuut, now that I import the files to FCE and try to play it with the editor, it only says "Codec could not be opened". And when I try to render it, it says "Codec not found. You may be using a compression type without the corresponding hardware card.". I figured there might be something wrong with the files since I moved them around from one computer to another with a USB flash drive and stuff, so I got new un-compressed .mkv files (1920x1080 x264 FLAC) and compressed them with Avidemux, with Huffyuv as the... codec (I'm sorry I'm this bad with technical stuff, this is why I'm asking for help) and .avi as the format. But the same problem repeats. So how should I save the files, or what should I download to get them to work? Thanks a lot in advance.

EDIT// okay I tried using MPEG-4 ASP (DivX) instead and after downloading DivX it worked in FCE. However, I get flashes of the DivX watermark, so is there any better options? Or do you know how can I get rid of the watermark?
User avatar
Yolko
 
Joined: 17 Aug 2006

Re: File problem with FCE ("codec could not be opened")

Postby LantisEscudo » Mon Jul 02, 2012 5:30 pm

Huffyuv is a much better option than DivX. If you install Perian ( http://perian.org ), the files should open in FCE without issues.
User avatar
LantisEscudo
 
Joined: 08 Mar 2001
Location: Vermont

Re: File problem with FCE ("codec could not be opened")

Postby Yolko » Tue Jul 03, 2012 5:56 am

Riiight, Perian was the thing I was missing since the last time! Totally forgot I deleted it at some point. Man I feel stupid now. :rofl: But thanks bunches!
User avatar
Yolko
 
Joined: 17 Aug 2006

Re: File problem with FCE ("codec could not be opened")

Postby Mister Hatt » Sat Jul 07, 2012 6:35 am

Obligatory "use utvideo", it has a QT component and everything now.
Mister Hatt
 
Joined: 25 Dec 2007
Status: better than you

Re: File problem with FCE ("codec could not be opened")

Postby TEKnician » Tue Jul 10, 2012 5:25 pm

Mister Hatt wrote:Obligatory "use utvideo", it has a QT component and everything now.

:up:

UNLESS, your outdated OSX version doesn't know wtf UTvideo is. (I'm guessing only because you're using FCE which 10.7 don't recognize)
Almost as hard as fighting a Holy Paladin.
User avatar
TEKnician
 
Joined: 04 Mar 2010
Location: Smack in the middle of the Pacific Ocean
Status: Not reading the spoilers or manga

Re: File problem with FCE ("codec could not be opened")

Postby Yolko » Tue Aug 14, 2012 4:09 am

Okay well I now also have UTvideo component installed (I work on an OSX 10.6.8., it did recognize it. I think.) and Perian as well, but somehow the same files (that I encoded as Huffyuv) that worked couple of weeks ago started giving me the "codec could not be opened" in FCE again. D: And obviously it doesn't open in QT. I'm really sorry to bother again but I just can't help how little I understand this codec stuff. Or any technical stuff actually.

A deadline is coming up and I tested around the other codecs in Avidemux again just to get some video to work (even though that's probably stupid if Huffyuv is the best one and there's some way to make it work), MGEP-4 AVC worked but the file is enourmous and I get, surprise surprise, the DivX watermark. Thanks tons in advance if you can suggest something that'll get the Huffyuv files to work or can tell some other good option to encoding. And sorry for being an idiot with technicalities. >___>
User avatar
Yolko
 
Joined: 17 Aug 2006

Re: File problem with FCE ("codec could not be opened")

Postby Anicsi » Fri Aug 31, 2012 9:04 am

I have codec issues all the time, but what's weird is that it worked for you before.
1. Have you tried reinstalling all the codecs/Perian?
2. If that doesn't work, try copying the clips/sequences into a new project file. Which project/timeline settings do you use?
3. Which audio codec do your files have? Or did you get rid of the audio anyway? FLAC is a bitch on Mac, but I'm guessing it's not that anymore, since you converted to Huffy anyway. Hmm....


TEKnician wrote:
Mister Hatt wrote:Obligatory "use utvideo", it has a QT component and everything now.

:up:

UNLESS, your outdated OSX version doesn't know wtf UTvideo is. (I'm guessing only because you're using FCE which 10.7 don't recognize)


Good to know, won't bother updating to 10.7, then. Wished they'd finally update FCE, though, last version was from 2004.
User avatar
Anicsi
 
Joined: 18 Jun 2007

Re: File problem with FCE ("codec could not be opened")

Postby Anicsi » Fri Aug 31, 2012 9:20 am

Yolko wrote:MGEP-4 AVC worked but the file is enourmous and I get, surprise surprise, the DivX watermark. Thanks tons in advance if you can suggest something that'll get the Huffyuv files to work or can tell some other good option to encoding. And sorry for being an idiot with technicalities. >___>


Btw, i'm still trying to comprehend how the MPEG-4 AVC files could be bigger than Huffyuv, because huffy is lossless, and mpeg-4 clearly isn't? And also, MPEG-4 AVC is x264 for me, not xvid/divx or anything like that.

Image

Or did you convert to MPEG-4 ASP Xvid?

Anyway, you should install x264 Encoder if you haven't already. Saved me so much trouble, also for final video export.

Download this (sorry, only temporary download because I can't access my MF account for some reason)
http://www.sendspace.com/file/e5vtd6

Drop it here:
Image
User avatar
Anicsi
 
Joined: 18 Jun 2007

Re: File problem with FCE ("codec could not be opened")

Postby jorgesalarcon » Sat Jul 20, 2013 6:10 pm

Were you able to make this work with all the suggestions made here?
jorgesalarcon
 
Joined: 20 Jul 2013

Re: File problem with FCE ("codec could not be opened")

Postby Anicsi » Tue Aug 06, 2013 3:36 pm

TEKnician wrote:
Mister Hatt wrote:Obligatory "use utvideo", it has a QT component and everything now.

:up:

UNLESS, your outdated OSX version doesn't know wtf UTvideo is. (I'm guessing only because you're using FCE which 10.7 don't recognize)



So I finally replaced my 5 year old macbook, on which i was running Leopard with FCE for the past few years. It worked just fine. I just wanted to ask if anyone knows if FCE is compatible with Lion and Mountain Lion.
I don't have my copy of FCE here (forgot it back home, yay), but I just want to know if it's wait it waiting to get home. I wanted to switch to Premiere at one point, but I still have some old FCE projects that I'd like to finish on my new computer if possible.

So... does FCE 4.0 run on Lion?

Replies are very much appreciated...
User avatar
Anicsi
 
Joined: 18 Jun 2007


Return to Mac Software

Who is online

Users browsing this forum: No registered users and 2 guests