AviSynth OSX 10.9.5 install problems

This forum is for questions and discussion of all the aspects of handling and cleaning up your footage with Avisynth.
Busty
Joined: Sun Jul 24, 2016 7:41 am
Org Profile

AviSynth OSX 10.9.5 install problems

Postby Busty » Wed Jul 27, 2016 11:14 am

Hi all,

I tried to install AviSynth using this guide: viewtopic.php?f=44&t=120468 (thanks Qyot27)

however some things didn't work out as described.


1) I couldn't update FFmpegSource2 as I didn't find a zip at the forum.doom9.org adress. Could someone point me to it?

2) And, I don't know what to do with the ffm2-2.22-msvc folder. How should I install the files in there?

3) Also, the LSMAHSource_r714-msvc2010.7z link on mediafire is down too. I settled forLSMASHSource-Avisynth-plugin-r879-msvc-32bit.7z

4) I couldn't delete mt_masktools-26.dll from the Avisynth plugins folder because it wasn't there in the first place.

5) I had to search for version 2409 of x264, it was replaced with a newer version. Since I didn't know about conflicts, I went with the older version.

6) When typing Wine regedit and navigating to "Environment", there is no PATH item on the right side. There's three items, called (Default), TEMP and TMP, respectively.


That leaves me with no clue how to even open VirtaulDub. Can someone please help me out?

User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby l33tmeatwad » Wed Jul 27, 2016 11:47 am

What that guide is thorough and explains how to manually setup wine, I would recommend this guide instead of you are trying to setup Wine and AviSynth as it will take care of placing everything where it needs to go for you.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube

Busty
Joined: Sun Jul 24, 2016 7:41 am
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby Busty » Wed Jul 27, 2016 1:23 pm

Hey l33teatwad, thanks for your input.

Actually, I tried your guide before this one, (on an 10.6.8 machine, if that matters), and it didn't work out either:

point no 24 to 29 never happens. I am not asked for installation for wine mono etc. When I choose (at point 23) "install some libraries", POM lets me search for what I want to install without the vcrun files.

BUT:
I just followed your guide on the Mavericks machine and the installation process seems complete there.

However, when I try to open an avs.script containing the line AVISource("test.avi"), I still get the error "Unable to open file: C:\Program Files\AviSynth\Plugins\test.avs".
The file "test.avi" is in the plugins folder too.

What can I do to make it work?

Thanks

User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby l33tmeatwad » Wed Jul 27, 2016 2:01 pm

Message me on Skype (via text chat), it'll be easier to troubleshoot on that instead of over the forum.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube

Busty
Joined: Sun Jul 24, 2016 7:41 am
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby Busty » Fri Jul 29, 2016 5:22 am

I'd like to, and thanks for the offer, but it seems I can't catch you online. Feel free to post insights here, in the meantime I leave skype open whenever I'm online.

User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby l33tmeatwad » Fri Jul 29, 2016 8:34 am

Since you only tried PlayOnMac with 10.6, I would suggest trying it with 10.9. I have had issues where the WINE install got messed up, so using bottled WINE (like PlayOnMac) so you can just refresh an install easily is probably the best method and it also takes care of configuring a lot of extra things. This issue with getting a lot of the updated AviSynth plugins working on WINE is having to know all the prerequisites that are usually natively installed on Windows and having to install them manually and figure out what DLLs to configure in WINE to make everything work. Try it again and let me know if you get any errors, since we can't meet up on Skype it's really hard for me to predict what errors you'll run into with a manual install of WINE. If it still fails at the same spot let me know and I'll let you know some alternative methods inside of PlayOnMac that should work around the issue you are having.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube

Busty
Joined: Sun Jul 24, 2016 7:41 am
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby Busty » Fri Jul 29, 2016 11:53 am

I tried it with 10.9 too (as I mentioned in my next to last post) and installation worked out as described. However, I still can't open files with AviSource.

I took a video with the codec FCP incompressed 10bit and saved it in Quicktime to a UTVideo codec, saved as mov. Neither VirtualDub (which doesn't concern me) nor Avisource opened the file. Avisynth is installed, I can open the avs where it shows the version ao AviSynth.

Should I use another codec/container?

Oh, and right now I have Skype open, name sonicbusty.

User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby l33tmeatwad » Fri Jul 29, 2016 12:16 pm

The reason AviSource won't work is because it's MOV, you will need to recontainer that MOV to AVI (if you have AMVpack use FFmpegYAG to accomplish that, just follow the directions for MKV to MP4 but select the MOV to AVI option instead).

PS. When you said the install seems complete I assumed you were talking about the other guide, not PlayOnMac, sorry about that.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube

Busty
Joined: Sun Jul 24, 2016 7:41 am
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby Busty » Sat Jul 30, 2016 4:25 am

i recompressed it with quicktime as DV as codec and avi as container (ffmpegyag gave me a runtime error on opening that file) and Virtualdub opens it, but AviSource still doesn't.

User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby l33tmeatwad » Sat Jul 30, 2016 8:46 am

If you could take a screenshot of the error that would help.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube

Busty
Joined: Sun Jul 24, 2016 7:41 am
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby Busty » Sat Jul 30, 2016 1:28 pm


User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby l33tmeatwad » Sun Jul 31, 2016 1:04 pm

Did you install AviSynth via AMVpack? If so, it it's possible the FFmpeg Input Plugin could be causing this issue. Does the script work in AvsPmod? If that is the case, try opening the script by opening VirtualDub, going to file, open, then selecting " AVIFile input driver" in the drop down.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube

Busty
Joined: Sun Jul 24, 2016 7:41 am
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby Busty » Mon Aug 01, 2016 4:18 am

Yes, I installed Avisynth via AMVPack as described in your installation guide.
In AvsPmod I noticed that in the script the path to the file was insufficient. I corrected that, but the file still won't open.

I might be blind or something, but I can't find the option "AVIFile input driver in Virtualdub, where should that be? When I open VirtualDub, go to the script file and open it, that's where I get the error message which I did the screenshot from.

What I find curious:

I open AvsPmod, go to Edit - Insert - Insert source so that AvsPmod writes the syntax. Then, when I go to Tools and select one of the two encoders, it says "The current Avisynth script contains errors. So it seems AvsPmod is creating a faulty script?

User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby l33tmeatwad » Mon Aug 01, 2016 8:04 am

For "AVIFile input driver", in VirtualDub go to FIle, then click "Open video file..." and in the "Files of type:" drop down box in the "Open video file" dialog, that will be the next to last option.

As for the script errors, post your script so I can see what you're working with.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube

Busty
Joined: Sun Jul 24, 2016 7:41 am
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Postby Busty » Mon Aug 01, 2016 12:22 pm

yeah, right, found it. As I said, I may be blind.

When opening via "AVIFile input driver", the error message goes:
"Avisynth open failure: AVISource couldn't locate a decompressor for fourcc dvsd (C:/Program Files\AviSynth\Plugins\test.avs, line 1)"

regarding the script, it's just this for the opening test: AVISource:("test.avi").

When I was opening the video file with AvsPmod (Edit - Insert - Insert source) it was scripting AVISource:("full path\test.avi"), so I thought I made a mistake in syntax. But I guess the full path name is just optional as long as the script is in the same folder as the avs.


Return to “AviSynth Help”

Who is online

Users browsing this forum: No registered users and 1 guest