AviSynth OSX 10.9.5 install problems

This forum is for questions and discussion of all the aspects of handling and cleaning up your footage with Avisynth.
User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Post by l33tmeatwad » Mon Aug 01, 2016 12:50 pm

There should be no : in there, it should just be AviSource("C:\filelocation\file.avi") and such. As for the "Couldn't locate the decompressor" it means that the codec is not installed inside of WINE. I would try again with Ut and see, since you installed AMVpack I know that it installs Ut codec (unless you unchecked it during the install process). Try creating the file without audio and see if you can get it to work, there could be an issue if you recontainer audio that's not compatible inside of AVI as well.

If you would like to install the DV codec you are using, try locating the windows installer and in PlayOnMac go to configure, click on AMVpack, then click on Miscellaneous, then click "Run a .exe file in this virtual drive", locate the installer and run it.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube

Busty
Joined: Sun Jul 24, 2016 7:41 am
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Post by Busty » Tue Aug 02, 2016 5:16 am

Success, thanks to you!

This morning it worked out. The problem was that I used codecs that weren't installed in the windows environment, as you pointed out.

When I convert the video to UTvideo codec and use as container avi, then the video opens in VirtualDub via AVISource. (The only application that can accomplish that - that I know of - is ffmpeg.)

Now, if I want to install some plugins like the QTGMC plugin package, should I go for the new plugin pack using the updated Avisynth 2.6 interface (as described here: http://forum.doom9.org/showthread.php?t=156028 ) or a different one and, just to make sure, how would I install them in PlayOnMac?

I just want to use avisynth to deinterlace with QTGMC with 50fps. Maybe I'll learn about some more plugins in the longer run, but this is the main goal right now.

Hey, and I'm really grateful that you took the time and walked this through with me. Thanks and keep it up!

User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Post by l33tmeatwad » Tue Aug 02, 2016 8:24 am

To install any codecs you can find the windows installer for, simply use the method I mentioned above to "Run a .exe in this virtual drive" once you have the windows installer.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube

Busty
Joined: Sun Jul 24, 2016 7:41 am
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Post by Busty » Tue Jul 18, 2017 5:47 am

How would I go about installing additional filters like toot.dll or similar in OSX? CAn I just put them into the plugins folder or do they have to register somehow / somewhere?

Busty
Joined: Sun Jul 24, 2016 7:41 am
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Post by Busty » Tue Jul 18, 2017 7:57 am

just tried it myself with the chromashift filter and it loads.I just put it in the plugins folder, so that seems to be it, if I'm not missing soemthing.

User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: AviSynth OSX 10.9.5 install problems

Post by l33tmeatwad » Tue Jul 18, 2017 10:16 am

To repeat what you already found to be true, you only need to place plugins in the plugins folder for AviSynth. That said, pay attention to any dependencies listed by the plugin documentation when adding new plugins as there may need to be something additional installed.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube

Locked

Return to “AviSynth Help”