Missing Audio In Virtual Dub

This forum is for questions and discussion of all the aspects of handling and cleaning up your footage with Avisynth.
Locked
Watatashi
Joined: Tue Jan 14, 2014 8:29 pm
Org Profile

Missing Audio In Virtual Dub

Post by Watatashi » Fri Dec 05, 2014 1:52 am

So I recently ripped some footage from a blu-ray disk using makeMKV and the mkv file plays perfectly fine in MPC with audio and flawless video quality. I have since tried loading this file into VirtualDub and the audio is suddenly missing. The audio stream is totally blank. What am I missing or what have I done wrong?

User avatar
Shui
Shuitcake
Joined: Sun Jul 02, 2006 6:27 am
Org Profile

Re: Missing Audio In Virtual Dub

Post by Shui » Fri Dec 05, 2014 2:52 am

How do you load it into VirtualDub? If via avisynth please show us your script.
Spoiler :
fucking stealing other poeples hard work and claiming it as your own, you guys should be ashemed

ppl fukin fuk spent years making those animes, blood sweat and spilt coffe stains drawing all day long just to get a title "animator: this GUY" and then those music ppl spend years learning to produce music, teams of so many hard working ppl just trying to get their stuff out there in the world then WHAT TEH FUK DO U GUYS DO? u fukin take the drawings, u fukin take the music, then u just slap it fukin together like its fukin nothing, then u make banners and og take credit for it fukin all like u fukin made shit goin amv contests actin liek ur teh fukin shit fukin sayin i amde this fukin liek if u fukin did fukin makin fukin the fukin fukin fukin fukin - MiyaDV (2014)

Watatashi
Joined: Tue Jan 14, 2014 8:29 pm
Org Profile

Re: Missing Audio In Virtual Dub

Post by Watatashi » Fri Dec 05, 2014 11:35 am

FFVideoSource("The Giver.mkv")

User avatar
RTW47
Joined: Sat Oct 30, 2010 10:48 am
Status: Knight of Ni
Location: Argument Clinic
Org Profile

Re: Missing Audio In Virtual Dub

Post by RTW47 » Fri Dec 05, 2014 12:10 pm

Watatashi wrote:FFVideoSource("The Giver.mkv")
you have to load audio track as well:

Code: Select all

FFMpegSource2("The Giver.mkv", atrack=-1) 

Watatashi
Joined: Tue Jan 14, 2014 8:29 pm
Org Profile

Re: Missing Audio In Virtual Dub

Post by Watatashi » Fri Dec 05, 2014 12:16 pm

Okay so now the audio shows up in the stream but the file doesn't seem to play. It just sits there frozen after I hit play.

User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: Missing Audio In Virtual Dub

Post by l33tmeatwad » Sun Dec 07, 2014 3:10 pm

If the audio had more the 2 channels (stereo) it will not play in VirtualDub but it will export just fine.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube

Locked

Return to “AviSynth Help”