MacOS Catalina install problems

This forum is for questions and discussion of all the aspects of handling and cleaning up your footage with Avisynth.
Post Reply
Appius
Joined: Sun Feb 21, 2021 4:01 pm
Org Profile

MacOS Catalina install problems

Post by Appius » Sun Feb 21, 2021 4:20 pm

I just did the install on MacOS via the instructions here: viewtopic.php?f=44&t=125120#p1546742

Things went more or less according to the instructions, with a couple of exceptions. One is that the AMV installer gave me two options. I used the AMVpack_200720_x86.exe versions. Then the system complained that it couldn't run that file (the new Gatekeeper functionality) after I selected it during the install, but when I hit "cancel" it seemed to complete the install anyway.

The other difference is that the UT component is not called "utvideo.component", but "utv_qt.component". Not sure that makes a difference.

Of the four apps that I made shortcuts for, the last two (DGIndex and VirtualDub) seem to run ok when launched. AvsPmod complains about not being able to find the dll's, even though they seem to be in the directory there: "[Error 126] file not found" and gives me the option of locating the dll's, but just returns to this error. I notice that the error talks about avisynth.dll but the actual file has different capitalization: AviSynth.dll. (It doesn't make a difference if I change the name to have all lowercase.)

Here's that path: /Users/username/Library/PlayOnMac/wineprefix/AMVpack/drive_c/windows/syswow64/AviSynth.dll

AMVtool crashes. I can share the log.

Finally in the config screen, my wine version says just "System". No choice to pick something with a version number.

Appius
Joined: Sun Feb 21, 2021 4:01 pm
Org Profile

Re: MacOS Catalina install problems

Post by Appius » Fri Mar 19, 2021 1:32 pm

No thoughts?

User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: MacOS Catalina install problems

Post by l33tmeatwad » Sat Mar 20, 2021 6:54 am

My recommendation would be to get AMVpack for macOS and use VapourSynth instead as it will run faster and more effectively since it's native tools, but if you really just want AviSynth then you need to provide accurate logs and spend time troubleshooting. There's a lot wrong going on here, if you cancelled something you probably need to start over as something is probably missing. Also you need to make sure if you are using the x86 Installer that you are using a x86 WINE core. Additionally, some of the new versions of PlayOnMac WINE cores cause issues, so you'll need to just randomly try older ones until you find one that works.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Twitter | YouTube

Post Reply

Return to “AviSynth Help”