ERROR: Link is not valid: 301 - Moved Permanently

Locked
User avatar
kyle_m
Joined: Wed Feb 03, 2010 8:04 pm
Status: i am doing O.K.
Location: possessions of Tsar MF Putin...
Org Profile

ERROR: Link is not valid: 301 - Moved Permanently

Post by kyle_m » Sat Sep 05, 2015 10:26 am

hi folks, anyones goin to fix subj on adding video links hosted elsewhere, vimeo 4 example

User avatar
GloryQuestor
Moderation Hero
Joined: Tue Apr 13, 2004 4:59 pm
Status: Always around, creating more AMVs. :)
Location: TN
Contact:
Org Profile

Re: ERROR: Link is not valid: 301 - Moved Permanently

Post by GloryQuestor » Sat Sep 05, 2015 11:09 am

kyle_m wrote:hi folks, anyones goin to fix subj on adding video links hosted elsewhere, vimeo 4 example
You should first check to see if you properly set up the external link for the video:
  • - On the website main menu, select "Edit Video Info";
    - Click on the title of the video with the link you need to revise;
    - Click on "Step 4: LINKS";
    - Double-check (and revise, if needed) the webpage link address and in the link type box:
    ...- If the link directly points to the video file itself, it is "Direct";
    ...- If the link is pointing to a video preview page or something other than the video file, it is "Indirect"
    - Click on "Step 6: COLLAB"
    - Click "Finish"
If it is still giving you problems, and you have used the right weblink and type, please let me know by PM which video it is and what the weblink should be, so that we can investigate further.

Thanks :)
Website Administrator, AnimeMusicVideos.Org
Samurai Warriors Productions
Pittsburgh Japanese Culture Society Events - AMV Department Head
Middle Tennessee Anime Convention - AMV Contest Manager & AMV Events
Anime Weekend Atlanta - Video Art Track Assistant Director of Programming

User avatar
kyle_m
Joined: Wed Feb 03, 2010 8:04 pm
Status: i am doing O.K.
Location: possessions of Tsar MF Putin...
Org Profile

Re: ERROR: Link is not valid: 301 - Moved Permanently

Post by kyle_m » Sat Sep 05, 2015 11:58 am

actually every utube or vimeo link now (and maybe other videohosts idk), i wonder no one reported yet.

Image

it was working some time ago as u described, but one day it stopped (probably one of those days utube service updated). i guess this error is a result of org's link validation logic, internal ping via http, which then says sites moved to another location. it's not a fault in terms of http, true location must be in returned packet headers, but org's internal logic stucks here, not allowing pass "add" button. direct or indirect does not matter. hm... probably it is a problem of a RU zone... of course sites which does not send 301 header, still allowed for addition

User avatar
Mol
Strawberry Pie
Joined: Thu Feb 22, 2007 2:28 am
Status: sutatS
Location: Sweden
Contact:
Org Profile

Re: ERROR: Link is not valid: 301 - Moved Permanently

Post by Mol » Sat Sep 05, 2015 12:11 pm

click near type and set direct to indirect?
I just checked and it does give error. Change http to https as vimeo seems to use it. (checked your link and it worked for me)
Still better than that MMO.
Image

User avatar
kyle_m
Joined: Wed Feb 03, 2010 8:04 pm
Status: i am doing O.K.
Location: possessions of Tsar MF Putin...
Org Profile

Re: ERROR: Link is not valid: 301 - Moved Permanently

Post by kyle_m » Sat Sep 05, 2015 12:33 pm

M'o'l wrote:click near type and set direct to indirect?
I just checked and it does give error. Change http to https as vimeo seems to use it. (checked your link and it worked for me)
sure changed to http, https just throws out "page not found", it's another type of error starting with 4xx. direct or indirect does not seem to make sense, i believe internal ping logic just sends simple http request in both ways and looking forward 200 OK...but it gives 301 from some day on now. as I said the absolutely same deal was working for years.

User avatar
GloryQuestor
Moderation Hero
Joined: Tue Apr 13, 2004 4:59 pm
Status: Always around, creating more AMVs. :)
Location: TN
Contact:
Org Profile

Re: ERROR: Link is not valid: 301 - Moved Permanently

Post by GloryQuestor » Sat Sep 05, 2015 12:38 pm

kyle_m wrote:
M'o'l wrote:click near type and set direct to indirect?
I just checked and it does give error. Change http to https as vimeo seems to use it. (checked your link and it worked for me)
sure changed to http, https just throws out "page not found", it's another type of error starting with 4xx. direct or indirect does not seem to make sense, i believe internal ping logic just sends simple http request in both ways and looking forward 200 OK...but it gives 301 from some day on now. as I said the absolutely same deal was working for years.
Okay, I'll let the techs know and see if they can track down if it's something in our codebase.
Website Administrator, AnimeMusicVideos.Org
Samurai Warriors Productions
Pittsburgh Japanese Culture Society Events - AMV Department Head
Middle Tennessee Anime Convention - AMV Contest Manager & AMV Events
Anime Weekend Atlanta - Video Art Track Assistant Director of Programming

User avatar
kyle_m
Joined: Wed Feb 03, 2010 8:04 pm
Status: i am doing O.K.
Location: possessions of Tsar MF Putin...
Org Profile

Re: ERROR: Link is not valid: 301 - Moved Permanently

Post by kyle_m » Sat Sep 05, 2015 12:41 pm

well, crap.... tried http://web-sniffer.net/

request to http://vimeo.com/138395317 just relocates to https...

GET /138395317 HTTP/1.1[CRLF]
Host: vimeo.com[CRLF]
....

HTTP Response Header
Name Value Delim
Status: HTTP/1.1 301 Moved Permanently
Server: nginx
Content-Type: text/html; charset=UTF-8
Location: https://vimeo.com/138395317
...

what the hell, how it is still working for u guise??? :O

Locked

Return to “Site Help & Feedback”