Zarx264gui 1.3

If you have questions about compression/encoding/converting look here.
User avatar
xnamkcor
Joined: Wed Jul 30, 2003 2:29 pm
Location: Mesa, AZ
Contact:
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by xnamkcor » Fri Nov 13, 2009 7:41 am

Zarxrax wrote:Ok, I put up a new one with fixed audio, but the cancel button is a bit screwed right now. This one is going to take me some time to get completely fixed.
Sorry for breaking it.
WE DRAMATIZE IT COMPLETELY!

User avatar
Kisuke_Urahara
Joined: Mon Dec 05, 2005 2:38 pm
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by Kisuke_Urahara » Sat Nov 14, 2009 5:23 am

Thanks for fixing the bugs I've mentioned :D .

Theres is still something wrong with psy rd when using the slow preset though.
Although the trackbar isn't reseted when switching to a different tab like it was before the value is still not shown in the command line.

I've made two screenshots:

(using preset slower and psy rd 1.52)
Image

(using preset slow and psy rd 1.52)
Image

Code: Select all

I'd rather be hated for who I am, than loved for who I am not. ~ Kurt Cobain

User avatar
Bauzi
Joined: Fri May 21, 2004 12:48 pm
Status: Under High Voltage
Location: Austria (uhm the other country without kangaroos^^)
Contact:
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by Bauzi » Mon Nov 16, 2009 8:00 am

Image (newest version, 1.31 beta5)

The new GUI crashes with a 720x400 video of mine. The gui crashes, but after closeing the error message the x264 process continues to encode the video. The old GUI encodes fine with no issues.


Command line from crashed gui:

Code: Select all

BePipe.exe --script "import(^D:\Projekte\AMV Projekte\Project Editor (2009) - Round 2\a.avs^).Normalize()" | neroAacEnc.exe -br 160000 -ignorelength -if - -of "D:\Projekte\AMV Projekte\Project Editor (2009) - Round 2\a-temp.m4a"
avs2yuv.exe "D:\Projekte\AMV Projekte\Project Editor (2009) - Round 2\a.avs" -raw - | x264_x64.exe --crf 20 --preset veryslow --tune animation --filter 1:1 --aq-strength 0.6 --psy-rd 0.4:0 --sar 80:81 --frames 2092 --fps 29.97003 --output "D:\Projekte\AMV Projekte\Project Editor (2009) - Round 2\a-temp.264" - 720x400
MP4Box.exe -fps 29.97003 -add "D:\Projekte\AMV Projekte\Project Editor (2009) - Round 2\a-temp.264" -add "D:\Projekte\AMV Projekte\Project Editor (2009) - Round 2\a-temp.m4a" -new "D:\Projekte\AMV Projekte\Project Editor (2009) - Round 2\a.mp4" -tmp "D:\Projekte\AMV Projekte\Project Editor (2009) - Round 2" 
I use Windows 7 Ultimate x64
New AMV: Don't Leave Me Alone
https://www.animemusicvideos.org/video/202928

User avatar
Zarxrax
Joined: Sun Apr 01, 2001 6:37 pm
Location: Concord, NC
Contact:
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by Zarxrax » Mon Nov 16, 2009 11:15 am

Looks like there's a problem when you specify an SAR. I'll check into it.

User avatar
Zarxrax
Joined: Sun Apr 01, 2001 6:37 pm
Location: Concord, NC
Contact:
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by Zarxrax » Mon Nov 16, 2009 2:15 pm

Ok, beta 6 is now up. All known problems should be fixed.

User avatar
Castor Troy
Ryan Molina, A.C.E
Joined: Tue Jan 16, 2001 8:45 pm
Status: Retired from AMVs
Location: California
Contact:
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by Castor Troy » Sat Nov 21, 2009 1:22 am

Tried to load a 720 x 480 huffy with the newest one and it crashes on Win 7 32bit for me. :(
"You're ignoring everything, except what you want to hear.." - jbone

User avatar
Castor Troy
Ryan Molina, A.C.E
Joined: Tue Jan 16, 2001 8:45 pm
Status: Retired from AMVs
Location: California
Contact:
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by Castor Troy » Sat Nov 21, 2009 1:27 am

Here's a screenshot..

Image
"You're ignoring everything, except what you want to hear.." - jbone

User avatar
Castor Troy
Ryan Molina, A.C.E
Joined: Tue Jan 16, 2001 8:45 pm
Status: Retired from AMVs
Location: California
Contact:
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by Castor Troy » Sat Nov 21, 2009 4:06 am

Update: It can load my much smaller files with smaller resolutions than 720 x 480, but nothing at that size or over. :(
"You're ignoring everything, except what you want to hear.." - jbone

User avatar
Zarxrax
Joined: Sun Apr 01, 2001 6:37 pm
Location: Concord, NC
Contact:
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by Zarxrax » Sat Nov 21, 2009 10:02 am

I can't seem to duplicate this problem. Is anyone else having this issue?

User avatar
Castor Troy
Ryan Molina, A.C.E
Joined: Tue Jan 16, 2001 8:45 pm
Status: Retired from AMVs
Location: California
Contact:
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by Castor Troy » Sat Nov 21, 2009 2:15 pm

I don't wanna encode in xvid again. :cry:
"You're ignoring everything, except what you want to hear.." - jbone

User avatar
Enigma
That jolly ol' bastid
Joined: Sat Mar 07, 2009 3:55 pm
Status: Free
Location: California
Contact:
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by Enigma » Sat Nov 21, 2009 2:58 pm

Castor Troy wrote:I don't wanna encode in xvid again. :cry:
Whats so wrong with XviD O.o

User avatar
Zarxrax
Joined: Sun Apr 01, 2001 6:37 pm
Location: Concord, NC
Contact:
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by Zarxrax » Sat Nov 21, 2009 4:59 pm

Soup wrote:Whats so wrong with XviD O.o
The fact that it sucks compared to x264.

User avatar
Qyot27
Surreptitious fluffy bunny
Joined: Fri Aug 30, 2002 12:08 pm
Status: Creepin' between the bullfrogs
Location: St. Pete, FL
Contact:
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by Qyot27 » Mon Nov 23, 2009 12:11 am

Castor Troy wrote:I don't wanna encode in xvid again. :cry:
There's always .bat scripts. And Zarx264gui can even output them for you. Or at least the skeleton of one where all you have to do is edit in the location of the input AviSynth script and output MP4 (or raw 264, or MKV; or FLV as of a couple revisions ago, which is also beneficial because weightp was finally committed*) and be done with it. Then just double-click the script and go get some coffee.


*And there isn't a problem with it, either. There's a known glitch in CoreAVC that affects the software-only decoding (doesn't happen for CUDA) when --weightp 2 is used, but that's not weightp's problem - it adheres to the standard, CoreAVC doesn't. ffdshow, on the other hand, has no problems playing back the files at all. And ffdshow really is more than fast enough now, especially if you use the ffmpeg-mt option for H.264 instead of plain libavcodec. It could play 1080p24 with softsubs at full speed on my mom's 1½-year-old HP laptop that's running Vista.
My profile on MyAnimeList | Quasistatic Regret: yeah, yeah, I finally got a blog

jakkor
Joined: Wed Feb 25, 2009 5:07 pm
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by jakkor » Tue Dec 01, 2009 5:03 am

I used latest beta to converting movie 25 hour hd 1280x720.
I set preset -slower, tune-film, 2pass encoding with bitrate video 450. Converting took about 8 hours. First pass speed about 25 fps, second about 8 fps.
My sample
http://hotfile.com/dl/19163848/534db59/sample.mp4.html
everything seems good.

User avatar
Zarxrax
Joined: Sun Apr 01, 2001 6:37 pm
Location: Concord, NC
Contact:
Org Profile

Re: Zarx264gui 1.3beta (need testers)

Post by Zarxrax » Wed Dec 09, 2009 7:28 pm

Since no one else has reported problems, I've upgraded this from beta to stable. No other changes at the moment.

Locked

Return to “Conversion / Encoding Help”