AvsPmod / VirtualDub help

Locked
Oiam
Joined: Sun Jan 24, 2016 7:09 am
Org Profile

AvsPmod / VirtualDub help

Post by Oiam » Thu Jul 28, 2016 4:10 pm

Hello all,

so i´ve followed this guide (https://pixelblended.com/amv101/en/prep ... e/blu-ray/) very closely - i´m currently at "C.7." - but now i have a question. Because i use an older film footage (Akira BD) the writer suggests using these lines in AvsPmod:

#Input video
LWLibavVideoSource("<title>_t##.mkv")
#Removes heavy film grain by reading two frames back and ahead
super = MSuper(pel=2, sharp=1)
backward_vec2 = MAnalyse(super, isb = true, delta = 2, overlap=4)
backward_vec1 = MAnalyse(super, isb = true, delta = 1, overlap=4)
forward_vec1 = MAnalyse(super, isb = false, delta = 1, overlap=4)
forward_vec2 = MAnalyse(super, isb = false, delta = 2, overlap=4)
MDegrain2(super, backward_vec1,forward_vec1,backward_vec2,forward_vec2,thSAD=400)

I don´t know what i should put after "LWLibavVideoSource" though. Since my footage is named "title04" i assumed it´s "LWLibavVideoSource("title04.mkv")". That didn´t work unfortunately since i´ve gotten 2 error messages when i opened the ".avs" file with VirtualDub after that.
Those contained something along those lines:
1. "av_get_audio_frame_duration2" not found in DLL "(...)AviSynth/Plugins/avformat-57"
2. Unable to open file "(...)/video.avs"

I downloaded the whole AMV app, so i wonder what it is that i´m missing?

I´m looking forward to some answers, thank you!

Oiam
Joined: Sun Jan 24, 2016 7:09 am
Org Profile

Re: AvsPmod / VirtualDub help

Post by Oiam » Fri Jul 29, 2016 4:35 am

*does not find any edit function*

Strange enough i figured something out and the 2 errors do not occur again. However now there is another one:

Avisynth open failure:
Script Error: There is no function named "LWLibavVideoSource"
(C:\AMV\video.avs, line1)

Did i forget to download something separate?

Oiam
Joined: Sun Jan 24, 2016 7:09 am
Org Profile

Re: AvsPmod / VirtualDub help

Post by Oiam » Fri Jul 29, 2016 5:04 am

*same again*

Sooo... apparently there really was something missing in the package, and i found it in this thread:
http://www.animemusicvideos.org/forum/v ... p?t=118456

Hopefully this will help future generations, lel.

User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: AvsPmod / VirtualDub help

Post by l33tmeatwad » Fri Jul 29, 2016 9:07 am

The forwarding link for the auto download of the Microsoft Visual C++ 2015 Redistributable in AMVpack was broken again so it wouldn't actually download and install it. I need to update the installer to pull up the page if the download fails, however the links should be working again.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube

Locked

Return to “Video & Audio Help”