Problem with mkv's in vdub

This forum is for video and audio help and discussion.
Kaitrono
Joined: Sat Jan 10, 2009 6:55 pm
Org Profile

Problem with mkv's in vdub

Postby Kaitrono » Sun Jun 16, 2013 7:19 pm

I have some episodes of Madoka magika in mkv format so I made an aviscript as follows:

Code: Select all

FFVideoSource("F:\anime\Madoka Magica\Puella Magi Madoka Magica Raw\Episode 1.mkv")
ConvertToRGB(matrix="rec709")

When I open the avs file in Virtualdub (1.9.10), the video quality goes from good to horrendous and I'm not sure why. See example.
As seen in media player classic:
Image
As seen in Vdub:
Image

I tried converting the mkv to an mp4 and had the same result as seen in vdub. Can anyone tell me what's going on and how to fix it?

Thanks,
Kaitrono

User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: Problem with mkv's in vdub

Postby l33tmeatwad » Sun Jun 16, 2013 10:50 pm

The problem is most likely an outdated version of ffmpegsource, get the latest version and the problem should be solved.
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube

Kaitrono
Joined: Sat Jan 10, 2009 6:55 pm
Org Profile

Re: Problem with mkv's in vdub

Postby Kaitrono » Mon Jun 17, 2013 12:59 am

Such a simple fix. Thanks! That did the trick.

User avatar
purplepolecat
Joined: Wed Feb 22, 2006 3:36 pm
Location: Vancouver, BC
Org Profile

Re: Problem with mkv's in vdub

Postby purplepolecat » Sun Aug 18, 2013 4:50 pm

I had the same issue, this fixed it. Thanks.

User avatar
Ojive
Joined: Sun Sep 13, 2009 10:05 pm
Org Profile

Re: Problem with mkv's in vdub

Postby Ojive » Thu Aug 22, 2013 1:56 am

ALL DAY

ALL F---ING DAY, running through about a billion absolute garbage converters, codec solutions and just plain insane gambits to get my video files actually rendering properly

And then I stumble upon this, and my problems are solved instantly

YOU, SIR, ARE A SAINT OF THE HIGHEST CALIBER

...In all non shouty seriousness, though, this was a massive headache and I am incredibly glad to see the tail end of it. I know that I got my initial plugin files from the AMVapp pack-suppose it's out of date? If so, I imagine a lot of people are gonna experience this same problem...

User avatar
mirkosp
The Absolute Mudman
Joined: Mon Apr 24, 2006 6:24 am
Status: (」・ワ・)」(⊃・ワ・)⊃
Location: Gallarate (VA), Italy
Contact:
Org Profile

Re: Problem with mkv's in vdub

Postby mirkosp » Thu Aug 22, 2013 6:29 am

Which is exactly why we would need a bit of an update to the avtech... but then I had no time to do it. >_>
Image

User avatar
l33tmeatwad
Joined: Wed Feb 16, 2005 3:22 pm
Status: Trolling
Location: Blacksburg, VA
Contact:
Org Profile

Re: Problem with mkv's in vdub

Postby l33tmeatwad » Thu Aug 22, 2013 1:48 pm

Personally I think they should take out filters like ffms2 or just remove the pack altogether and just provide links (which will always be up to date).
Software & Guides: AMVpack | AMV 101 | AviSynth 101 | VapourSynth 101
PixelBlended Studios: Website | Facebook | Tumblr | Twitter | YouTube


Return to “Video & Audio Help”

Who is online

Users browsing this forum: Oiam and 2 guests