Vdub does not save audio

This forum is for video and audio help and discussion.

Vdub does not save audio

Postby Bargins » Thu Dec 27, 2012 4:36 am

Hello everyone,

yesterday I have decided to make first AMV on my new PC using AEE CS6. As the program does not support .mkv files I have spent all morning today trying to open my footage on Virtual Dub via Avisynth and finally became succesful. Yet when I try to save my .avi file it has no audio. Maybe I don't have some codecs or haven't checked some box or something..?

Codecs I have at the moment:
-Latest Xvid codec
-Latest DivX codec
-Latest CCCP codec pack
-Latest ffdshow
-Latest Haali Media Splitter
-Avisynth 2.5

Oh, and by the way. When I'm trying to compress audio with mpeg layer-3 it gives me weird error.
Image

Thanks in advance! :)
Bargins
 
Joined: 27 Dec 2012

Re: Vdub does not save audio

Postby mirkosp » Thu Dec 27, 2012 11:59 am

If you're using
Code: Select all
ffvideosource("blabla.mkv")

To load the file, it's going to be video only.
If you need the audio too, you can do
Code: Select all
ffcopyrightinfringement("blabla.mkv")

which is one of the functions included in the avsi. Assuming this does not work, it is just a shorthand for
Code: Select all
audiodubex(ffvideosource("blabla.mkv"),ffaudiosource("blabla.mkv"))

which should work.
At that point the audio is loaded.

As for the vdub error, I have never encountered it... it should be basically saying there's missing audio somewhere along the line thus vdub can't do its magic, but I'll leave it to MisterHatt just to be sure.
Image
User avatar
mirkosp
MODkip
 
Joined: 24 Apr 2006
Location: Gallarate (VA), Italy
Status: (」・ワ・)」(⊃・ワ・)⊃

Re: Vdub does not save audio

Postby Bargins » Fri Dec 28, 2012 2:53 am

mirkosp wrote:If you're using
Code: Select all
ffvideosource("blabla.mkv")

To load the file, it's going to be video only.
If you need the audio too, you can do
Code: Select all
ffcopyrightinfringement("blabla.mkv")

which is one of the functions included in the avsi. Assuming this does not work, it is just a shorthand for
Code: Select all
audiodubex(ffvideosource("blabla.mkv"),ffaudiosource("blabla.mkv"))

which should work.
At that point the audio is loaded.

As for the vdub error, I have never encountered it... it should be basically saying there's missing audio somewhere along the line thus vdub can't do its magic, but I'll leave it to MisterHatt just to be sure.


It does not work.. I get this message
Image
I was using directshowsource script and I have found out one thing. It actually saves audio but does not play it for some reason.
http://i50.tinypic.com/2jb8j2o.png (image couldn't fit)

Maybe I'm missing some codec or something. I don't know.. Damn, it's so demotivating... :(
Bargins
 
Joined: 27 Dec 2012

Re: Vdub does not save audio

Postby mirkosp » Fri Dec 28, 2012 3:08 am

Ugh, don't use directshowsource. I assumed you were using ffvideosource since you said you didn't have the audio.

https://code.google.com/p/ffmpegsource/ ... z&can=2&q=

This should be fine for your purposes. Extract .dll, .avsi, and .exe directly inside the plugins folder of avisynth, at that point you should be able to use the function that didn't work.


Either way, yes, dss loads audio by default, so clearly something else went wrong somehow, but I wouldn't really be able to know what exactly at this point...
Have you tried the "File" > "Save wav" option from virtualdub? That might work out for your needs, although uncompressed audio can be pretty big (much less than uncompressed video, but still).
Image
User avatar
mirkosp
MODkip
 
Joined: 24 Apr 2006
Location: Gallarate (VA), Italy
Status: (」・ワ・)」(⊃・ワ・)⊃

Re: Vdub does not save audio

Postby Bargins » Fri Dec 28, 2012 4:08 am

It worked! I downloaded the files you suggested and everything works fine!! Thank you very much!
Bargins
 
Joined: 27 Dec 2012


Return to Video & Audio Help

Who is online

Users browsing this forum: No registered users and 2 guests