Avidemux Exporting Incorrectly?

For discussion on Mac software and video editing on Mac computers.

Avidemux Exporting Incorrectly?

Postby IntheEvening » Fri Feb 24, 2012 8:51 pm

Hey all! I'm having some issues with Avidemux (version 2.5.4)

In my settings, I have the Video set to a Huffyuv, and the format as an MP4; everything seems to export fine (the video icon on my desktop shows the quicktime MPEG4 icon and all that, as opposed to a blank page icon) but when I try to play the footage, Quicktime tells me, "The movie contains some invalid data" and quits. I attempted to import the footage into iMovie 6 and was given the message, "The file could not be imported: The file “Macintosh HD/Users/Vespertine/Desktop/Spirited Away 1.mp4” can’t be imported; QuickTime couldn’t parse it: -2010."

Did I rip the footage incorrectly, perhaps? Or is it strictly a problem with Avidemux? (I do have Perian installed... And I'm on a Mac OS X 10.6.8, if that makes any difference)

If anyone knows where I went wrong, I'd really appreciate some help!
User avatar
IntheEvening
 
Joined: 22 Feb 2012

Re: Avidemux Exporting Incorrectly?

Postby Mister Hatt » Mon Mar 19, 2012 1:28 am

Don't use avidemux.
Mister Hatt
 
Joined: 25 Dec 2007
Status: better than you


Re: Avidemux Exporting Incorrectly?

Postby IntheEvening » Mon Mar 19, 2012 1:38 pm

LantisEscudo wrote:Huffyuv isn't a valid codec for MP4s. Try using an AVI instead.

Aaah, gotcha. Oversight on my part. Thanks very much!

Mister Hatt wrote:Don't use Avidemux

Recommended alternative? Preferably one that doesn't require me to run windows software?
User avatar
IntheEvening
 
Joined: 22 Feb 2012

Re: Avidemux Exporting Incorrectly?

Postby Mister Hatt » Fri Mar 23, 2012 5:08 am

Depends what you're trying to do. I use vdub in Parallels on my macbook with some crazy commandline stuff for integration, but I also have Audition and a custom IVTC program that run natively. Can't recommend anything if I don't know what it is you're doing. If you're just wanting to convert stuff, I have a brew formula for libav somewhere and a small shellscript for taking an input and converting to a useful output. It's quite easy.
Mister Hatt
 
Joined: 25 Dec 2007
Status: better than you

Re: Avidemux Exporting Incorrectly?

Postby IntheEvening » Fri Mar 23, 2012 1:26 pm

I was using Avidemux mainly for de-interlacing, and aspect ratio. Then I would take the AVI files and convert them to MOV using MGEP StreamClip... Honestly, I only have a pretty basic idea of what I'm doing, so I'm open to trying new stuff if you can give me a little direction on how to get it all set up.
User avatar
IntheEvening
 
Joined: 22 Feb 2012

Re: Avidemux Exporting Incorrectly?

Postby Mister Hatt » Sat Mar 24, 2012 3:11 am

Avidemux gets the aspect ratio wrong anyway. The basic rule for AR is that resizing changes the PAR and cropping changes the DAR. You want to make your PAR 1:1. You can use an AR calculator (google ar-calc.pl or something) to do that, and you're better off doing it in your NLE or avconv to do it correctly as Avidemux doesn't.

As for deinterlacing, it really depends on your content but IMO there is no good way to do it outside of Windows. Even libav's filters aren't ports of good Windows algorithms that I know of so you won't get a good result there. Your best bet is a lightweight Windows install in Parallels and using avisynth. You can also do that in wine/avs2yuv if you are familiar with commandline, and it'll do a better job on AR as a bonus.

Unfortunately, you can try to do all this in OSX or Linux but it really isn't the same. People are working on fixing it, but well it's a while off. I'm pretty tempted to write a small app that takes YUV input/output and handles interlacism though, but I just use avisynth for now.
Mister Hatt
 
Joined: 25 Dec 2007
Status: better than you

Re: Avidemux Exporting Incorrectly?

Postby IntheEvening » Sat Mar 24, 2012 12:34 pm

Mister Hatt wrote:Unfortunately, you can try to do all this in OSX or Linux but it really isn't the same.
Unfortunate, indeed.

I'll be giving all this a try, thanks for your help!
User avatar
IntheEvening
 
Joined: 22 Feb 2012


Return to Mac Software

Who is online

Users browsing this forum: No registered users and 0 guests