Odd preview behavior (incorrect aspect ratio)

For help and discussion concerning the Sony Vegas software.

Odd preview behavior (incorrect aspect ratio)

Postby Cannonaire » Mon Oct 11, 2010 10:34 am

I'm using Vegas Movie Studio 10.

Here's the issue I'm having: I'm editing a video using a single 16:9 source (FF7 Advent Children in case it matters). I have made clips without resizing, so they are all 720x480. I do not intend to do any kind of hard-resizing, but instead plan to do a soft resize using flags (final encode will be x264, flac, mkv). I set the project properties to use a Pixel Aspect Ratio of 1.2154 (close to NTSC-DV Widescreen, but more exact. Number taken from the AR calc here: http://ps-auxw.de/cgi-bin/ar-calc.pl). The preview window displays at 875x480, which WOULD be correct except that instead of stretching the video to fill this space, all it does is add black borders to the side to fill it (as shown in the screenshots). Setting the project properties to 1.0 PAR, the preview area displays the image exactly the same, except without the borders and at 720x480, the source resolution. Upon export, both settings give me the same result, that is, video in 720x480 without black borders or any kind of resizing, just as it is in the clips. The final output is therefor correct, except I have two concerns:

1. Is there a way to make the preview window stretch the footage instead of adding borders so I can see it correctly as I edit?
2. I'm concerned that any overlays or effects I add will display incorrectly in the final output, such as going into the black space of the borders which only exist in the preview area.

Addendum:
When i use a 4:3 DVD source, also kept in native 720x480 resolution, the preview window adds borders to the top and bottom, but it also does in fact squeeze the image to display according to the PAR I set in project settings. In this case as well, the final output upon export is the same regardless of the project settings, as in 720x480 at 1:1 ratio sans borders, which is an ideal result. This means I am only having issues with 16:9 footage.

Screenshots:

Preview window as viewed with project settings of 1.0 PAR
Image

Preview window as viewed with project settings of 1.2154 PAR
Image

I have also verified that using the built-in NTSC-DV widescreen option, which is close, has the same (incorrect) behavior, but the total display area is slightly different (873x480 instead of 875x480).
Image Think millionaire, but with cannons. || Resident Maaya Sakamoto fan.
User avatar
Cannonaire
 
Joined: 05 May 2010
Location: Oregon
Status: OVERLOAD

Re: Odd preview behavior (incorrect aspect ratio)

Postby Cannonaire » Mon Oct 11, 2010 12:21 pm

I figured it out. You have to click on each clip, individually (just like when you disable resample), and set them all to the correct PAR. What a hassle, but I can understand why Vegas does it this way.
Image Think millionaire, but with cannons. || Resident Maaya Sakamoto fan.
User avatar
Cannonaire
 
Joined: 05 May 2010
Location: Oregon
Status: OVERLOAD


Return to Sony Vegas

Who is online

Users browsing this forum: No registered users and 2 guests