Magix hates Lagarith? Or something else?

For help and discussion about specific video editing systems like Adobe software, Windows Movie Maker, Magix, Sony Vegas, etc. Please note the subforums.

Magix hates Lagarith? Or something else?

Postby dj_ultima_the_great » Sat Apr 28, 2007 5:35 pm

I'm using Magix Movie Edit Pro 10, and I've run into a strange and irritating issue.

Thing is, it seems like clips encoded with Lagarith will occasionally go glitchy on me in Magix. The original cleaned/rendered clips themselves are fine, but once I throw them into Magix, it shows a glitch in the preview window and it renders it that way too. The glitches have the frequency of about once or twice per clip, and they only last for a few frames at most.

A glitch, and what it's supposed to look like.

Also, if it helps, my cleaning Avisynth script:

Code: Select all
#ASYNTHER Default (AVISource)
AVISource("C:\Onimusha 4\1\Oni 4.01.01.avs")
crop(0,0,0,-144)
lanczosresize(640,360)
converttoyv12()
msharpen()
temporalcleaner()


The immediate solution seems to be to edit with Huffyuv instead (since it doesn't appear to show the same problem, although I haven't thoroughly tested it), but... well, those are nearly twice the size of my Lag clips. I'd like to avoid it if it's a problem I can correct.

Thanks for any help you can offer.


- Jen
User avatar
dj_ultima_the_great
 
Joined: 22 Dec 2003
Location: Wisconsin
Status: Resident Videogame Editor

Postby Sub0 » Sat Apr 28, 2007 9:00 pm

Idunno, but I'd guess your feilds are messed up. Could be caused by something as simple as you've got a conflicting program open (in that case just close it -_-) to something as complicated as your editing program just spit out a pos and I've no idea why.

Anyway try exporting it in uncompressed, that fixes alot of things.
User avatar
Sub0
 
Joined: 16 Nov 2001
Location: a small cabin on the edge of sanity

Postby Phantasmagoriat » Sat Apr 28, 2007 10:15 pm

dj_ultima_the_great wrote:Magix hates Lagarith? Or something else?

I for one believe Magix hates Lagarith 8-), maybe we should pole the other Magix users...

Occasionally, changing to rgb by adding ConverttoRGB32() to the end of your script helps [I'm not sure what colorspace Magix uses... but that may have something to do with it...]. Also, using an avs wrapper [like makeAVIS from ffdshow] can help... if it works correctly, you can use the same clips, but load them into Magix via an avswrapper.avi that's connected to an .avs script that has converttorgb32() added to the end.
...if that makes sense... hope it helps :)
Image
Org Profile | AMVGuide | Phan Picks! | THE424SHOW | YouTube | "Galactic Escape"

"Effort to Understand; Effort to be Understood; to See through Different Eyes."
User avatar
Phantasmagoriat
 
Joined: 06 Feb 2006
Status: ☁SteamPunked≈☂

Postby Willen » Sun Apr 29, 2007 5:07 am

http://www.animemusicvideos.org/phpBB/v ... hp?t=78686

There are issues with Lagarith in Magix, and a few solutions.

1. Try using a newer version of Lagarith. (Some people have had issues with 1.3.12. If this is your case, you'll want to stick with 1.3.10. But clips made with a newer version may not work well (if they work at all) playing back with an older version.)
2. Don't use the multi-threading option when encoding with Lagarith.
3. Use RGB32 colorspace.
4. Switch to Huffyuv. :(
Having trouble playing back videos? I recommend: Image
User avatar
Willen
Now in Hi-Def!
 
Joined: 10 Jul 2005
Location: SOS-Dan HQ
Status: Melancholy

Postby dj_ultima_the_great » Sun Apr 29, 2007 12:42 pm

Well, after reading that other thread, as well as the suggestions here, I think my safest route is to just use Huffyuv. Yeah, it's bigger, but it's definitely more reliable for Magix users, it seems.

Um... one last question. When I finish a project, I can export to Huffyuv in Magix and convert to Lagarith in VDubMod, right? Will that mess anything up? I ask because Lagarith seems to be the preferred submission codec of most MEPs.

Thanks.


- Jen
User avatar
dj_ultima_the_great
 
Joined: 22 Dec 2003
Location: Wisconsin
Status: Resident Videogame Editor

Postby JaddziaDax » Sun Apr 29, 2007 2:20 pm

i was going to say: considering my friend buma has issues with lagarith and he uses magix O.o perhaps its quite possible that the program doesnt like the codec?
User avatar
JaddziaDax
Crazy Cat Lady!
 
Joined: 16 Mar 2004
Location: somewhere i think O.o
Status: I has a TRU Arceus

Postby Willen » Mon Apr 30, 2007 4:39 am

dj_ultima_the_great wrote:Um... one last question. When I finish a project, I can export to Huffyuv in Magix and convert to Lagarith in VDubMod, right? Will that mess anything up? I ask because Lagarith seems to be the preferred submission codec of most MEPs.

Thanks.


- Jen

It's an extra step, but that will work. Actually, you may need to run the final Huffyuv export through VDubMod anyway if you need to combine the AVI segments that Magix will output if your video is long enough. There is a 2GB file size cap for Huffyuv AVI output from Magix (it's due to older Video for Windows AVI restrictions, but Magix hasn't gotten around to updating VfW AVI exporting to handle the larger files, and may never do so since Microsoft is pushing use of DirectShow over VfW development).
Having trouble playing back videos? I recommend: Image
User avatar
Willen
Now in Hi-Def!
 
Joined: 10 Jul 2005
Location: SOS-Dan HQ
Status: Melancholy

Postby 808-buma » Thu May 03, 2007 3:13 pm

I think that others not using magix but using the newer releases of LAGS are also having this problem too. I believe that I'm having this problem with the codec itself and NOT with Magix as I do all my clip encoding in VDMod and it produced errors using LAGS. So I wouldn't use any of the newer releases of LAGS until they fix the problem...

so it looks like I go back to 1.3.10, which I've never had a problem with, until they release a newer version that actually fixes the problem and not just minimizes it...
Image
ImageImageImageImage
User avatar
808-buma
 
Joined: 25 Apr 2005


Return to Video Editing Software

Who is online

Users browsing this forum: No registered users and 1 guest