Audio skipping

For help and discussion concerning the Windows Movie Maker software.

Audio skipping

Postby digifreak » Sat Aug 09, 2008 12:07 pm

You know how whenever you save as a DV-AVI it sometimes makes the audio all skippy. Is there any way to avoid that besides replacing the audio in Vdub? I tried doing that but the sync gets thrown off and I can't seem to get the delay just right. I'm using .wav audio. Is there another format that doesn't skip when it's saved as DV-AVI?
User avatar
digifreak
 
Joined: 06 Jun 2004

Postby JaddziaDax » Sat Aug 09, 2008 3:11 pm

you can try saving as a really high quality WMV file and use avisynth to open it in Virtualdub Mod...

and to replace audio in Vdubmod you go to
Streams->streams list-> disable the currently attached stream, and then add a new stream O.o
User avatar
JaddziaDax
Crazy Cat Lady!
 
Joined: 16 Mar 2004
Location: somewhere i think O.o
Status: I has a TRU Arceus

Postby digifreak » Sun Aug 10, 2008 12:14 pm

JaddziaDax wrote:you can try saving as a really high quality WMV file and use avisynth to open it in Virtualdub Mod...

and to replace audio in Vdubmod you go to
Streams->streams list-> disable the currently attached stream, and then add a new stream O.o

Thanks, and yeah I know how to replace the audio.
I'm replacing the stream, but it looks like WMM cut out a few frames from the beginning when it saved it, so it throws off the audio when I replace the stream. I'm trying to figure out how many milliseconds to subtract to get it back on sync.
User avatar
digifreak
 
Joined: 06 Jun 2004

Postby Autraya » Sun Aug 10, 2008 8:50 pm

are you editing with a VBR mp3? Or well any kind of mp3?

Try using a .wav instead
new banzors in the making :p
User avatar
Autraya
Zero Punctuation
 
Joined: 11 Mar 2003
Location: Terra Australis
Status: old

Re: Audio skipping

Postby Vivaldi » Sun Aug 10, 2008 9:32 pm

digifreak wrote:You know how whenever you save as a DV-AVI it sometimes makes the audio all skippy. Is there any way to avoid that besides replacing the audio in Vdub? I tried doing that but the sync gets thrown off and I can't seem to get the delay just right. I'm using .wav audio. Is there another format that doesn't skip when it's saved as DV-AVI?


-_-
Image
Image
<Kenzichu> HAHAHA!!
<Kenzichu> everyone died!
User avatar
Vivaldi
Polemic Apologist
 
Joined: 29 Sep 2007
Location: Petting mah cat..

Postby Autraya » Mon Aug 11, 2008 11:16 pm

lol, that'll teach me to go into auto mode answering these sorts of threads :P

is the delay during playback before or after exporting? (which could be your media player skipping on the large file or WMM lagging as per usual during playback.)

or are we talking about your actual audio playback is jumping all over the shop?
new banzors in the making :p
User avatar
Autraya
Zero Punctuation
 
Joined: 11 Mar 2003
Location: Terra Australis
Status: old

Postby digifreak » Wed Aug 13, 2008 3:15 pm

Autraya wrote:is the delay during playback before or after exporting? (which could be your media player skipping on the large file or WMM lagging as per usual during playback.)

or are we talking about your actual audio playback is jumping all over the shop?

After exporting. I never really use playback anyway.

It just skips a little in a few parts.
User avatar
digifreak
 
Joined: 06 Jun 2004

Postby digifreak » Wed Aug 13, 2008 3:16 pm

Oh yeah, how do you open .wmv in Vdub?
User avatar
digifreak
 
Joined: 06 Jun 2004

Postby Kariudo » Wed Aug 13, 2008 11:02 pm

IIRC, avisynth is the way to go there
ImageImage
Image
User avatar
Kariudo
Twilight prince
 
Joined: 15 Jul 2005
Location: Los taquitos unidos
Status: 1924 bots banned and counting!

Postby digifreak » Thu Aug 14, 2008 7:17 am

digifreak wrote:
Autraya wrote:is the delay during playback before or after exporting? (which could be your media player skipping on the large file or WMM lagging as per usual during playback.)

or are we talking about your actual audio playback is jumping all over the shop?

After exporting. I never really use playback anyway.

It just skips a little in a few parts.

I think I figured out what happened. When it saved it as DV-AVI it cut parts of the video as well as the audio. That's why I couldn't get the sync right by replacing the audio, cuz frames of the video were missing.
User avatar
digifreak
 
Joined: 06 Jun 2004

Postby Autraya » Fri Aug 15, 2008 12:11 am

This has happened before I dont know what really is causing it tho, I wonder;
are the project settings for frame rate and the clips you imported the same?
new banzors in the making :p
User avatar
Autraya
Zero Punctuation
 
Joined: 11 Mar 2003
Location: Terra Australis
Status: old

Postby digifreak » Wed Aug 20, 2008 1:41 pm

Autraya wrote:This has happened before I dont know what really is causing it tho, I wonder;
are the project settings for frame rate and the clips you imported the same?

How do I check?

Also, which is the best quality .wmv that WMM can save a movie as? I was reading the guides and it said it's Video for local playback (2.1Mbps NTSC), but I wanted to be sure.
User avatar
digifreak
 
Joined: 06 Jun 2004


Postby Hareoic » Fri Oct 03, 2008 12:46 pm

2.1Mbps is the best quality WMV that I've seen thus far (unless the variable bit rate WMVs are better than that).

But yeah, I don't know why DV-AVI does that. It's happened to me, too, and I don't know how to fix it.
User avatar
Hareoic
 
Joined: 30 Jan 2008
Location: Omaha
Status: IT'S PAAHFEKKTO

Postby JaddziaDax » Fri Oct 03, 2008 1:47 pm

necroposts?
User avatar
JaddziaDax
Crazy Cat Lady!
 
Joined: 16 Mar 2004
Location: somewhere i think O.o
Status: I has a TRU Arceus

Next

Return to Windows Movie Maker

Who is online

Users browsing this forum: No registered users and 2 guests