Odd Premiere CS3 Import Behavior

Discussion and help related to Adobe video software goes here. e.x. Premiere, After Effects, Photoshop, etc.

Odd Premiere CS3 Import Behavior

Postby JediNight » Mon May 04, 2009 12:44 am

I've been transcoding source to Lagarith lossless AVI over the past few days. Now I'm noticing that Ep7+ of my lossless files only import as 2m22s long. They open in Vdub and MPC-Home Cinema just fine at the correct full length. Properties in Premiere for the files properly detect them as ~34000 frames long, but think they are only the 2m22s.

I haven't changed anything between encoding those episodes, so I'm at a loss as to why it would be that way. I tried re-registering CCCP and Avisynth just in case, but that hasn't helped. I tried seeing if it would detect them properly via Avisynth import, but the plugin doesn't appear to work properly in my CS3 -- it claims it doesn't have the proper codec, despite the AVS opening in everything else normally as well.

Anyone got any ideas what the problem might be? 2m22s shouldn't even be the 2gb mark on a ~12gb file ... more like the 1.3gb point so I'm out of ideas.
JediNight
 
Joined: 02 Dec 2005

Re: Odd Premiere CS3 Import Behavior

Postby JediNight » Mon May 04, 2009 3:15 am

Update on the odd behavior: Encoded a random 2m39s clip from an episode (1.3gb) that imported properly. Then took a 7min 3.6gb clip from the same episode and it imported 1.07 secs...
JediNight
 
Joined: 02 Dec 2005

Re: Odd Premiere CS3 Import Behavior

Postby blabbler » Mon May 04, 2009 2:45 pm

sounds like the 23.976 fps bug, try creating a new 24fps sequence and importing the files, then right click the clips in the project window and choose interpret footage > assume frame rate: 24fps before you drop them onto the timeline.

if that doesn't work, try re-encoding the footage at 24fps

"assumefps(24)" in avisynth
Image
User avatar
blabbler
 
Joined: 09 Nov 2007
Location: Copycat_Revolver's fetid imagination

Re: Odd Premiere CS3 Import Behavior

Postby JediNight » Mon May 04, 2009 7:51 pm

That doesn't seem to work either, sigh. It seems to randomly not work as well... I took a 5min clip using Normal recompress as a test and that actually imported the full length. Then I tried the full episode at Normal recompress and it only imported 2m22s again. Next attempt I guess will be to try encoding in Huffyuv instead of Lagarith.

It's frustrating because the deadline for Otakon is only a month away and I want to have it finished by them, and I'm getting hung up on source sigh...
JediNight
 
Joined: 02 Dec 2005

Re: Odd Premiere CS3 Import Behavior

Postby blabbler » Tue May 05, 2009 11:13 am

you've tried encoding them with the "assumefps(24)" command in the avs script? this is exactly the same problem that drove me nuts a few months ago.



generally you would want to use fast recompress out of vdub

add "assumefps(24)" or "assumefps(30)" to the end of your avs script
in vdub try
save as> blahblah
fast recompress
lagarith (make sure "enable null frames" isn't checked under configure)

import into a new sequence in a new project with the appropriate frame rate

it may also help if you giggle in a sinister fashion while cutting the palms of your hands with a craft knife, as you wait for the encode to complete
Image
User avatar
blabbler
 
Joined: 09 Nov 2007
Location: Copycat_Revolver's fetid imagination

Re: Odd Premiere CS3 Import Behavior

Postby JediNight » Tue May 05, 2009 7:35 pm

Yeah I always used fast recompress, but I was just grasping at straws :)

The Assumefps(24) did finally fix my problem btw. No clue why the first 6 episodes encoded just fine without doing that, though. Should I just import and use the footage as 24.00fps, or should I then Interpret footage as 23.976 as well?

Encode times are fine, since it's just a transcode. Anywhere from 22-27mins per encode, and I set up a giant queue in Vdub job control to go through them all when I'm asleep. Of course since life hates me, Win7 power management screws with the job control, so it will just encode 1-2 episodes then sit at 0% on the next one until I come back and move the mouse ... then it magically starts going again. I even set Power options to High Performance and turned off any sleep or spindown functions etc.

I'm using Vdub 1.8.8 atm, maybe I'll try a different version and see if that fixes the issue. I just got the 1st season converted, but now I have all of the 2nd season to convert. 650gb of footage to import in the end, hooray -_-;;
JediNight
 
Joined: 02 Dec 2005

Re: Odd Premiere CS3 Import Behavior

Postby blabbler » Wed May 06, 2009 4:05 am

i'd start at the end and look at what format you want to deliver... if it's just for viewing on computer monitors, and you don't intend to use the original anime audio it really doesn't matter what you do.

however, you will want to ensure that the clips on your timeline are interpreted as the same framerate as your timeline.
so if you decide to make a 23.976 project using your 24fps footage, be sure to interpret the footage at 23.976.

just be aware that interpret footage, like assumefps, does change the playback speed, so interpreting 24fps footage at 30fps will speed it up significantly, while 23.976 to 24 won't be noticeable.

if you need to deliver progressive and interlaced versions (like an org version and a con/dvd version), this stuff starts to become more important.

ps. mebbe your comp has a separate power management app running in the background?
Image
User avatar
blabbler
 
Joined: 09 Nov 2007
Location: Copycat_Revolver's fetid imagination


Return to Adobe Software

Who is online

Users browsing this forum: No registered users and 2 guests