Bars of color instead of gradients?

This forum is for questions and discussion of all the aspects of handling your footage. If you have questions about capturing/ripping footage, AviSynth, or compression/encoding/converting, look here.

Bars of color instead of gradients?

Postby dreamoflife02 » Tue Dec 26, 2006 2:32 pm

So in my AMV, whenever the footage is moving wherever there is supposed to be a gradient I get these ugly blocks of color instead. However, when it's stopped on one frame, the gradient looks fine. Is there something I have to add into my script to fix that? My script as it is now:

ConvertToYV12()
deen("w2d",6,7,9)
Temporalcleaner()
mfrainbow(strength=255)
ConvertToRGB24()

(I have to convert it twice because I use TMPGEnc.)
User avatar
dreamoflife02
 
Joined: 22 Apr 2006

Postby Zarxrax » Tue Dec 26, 2006 4:02 pm

How are you viewing it? In virtualdub? That problem could be caused by virtualdub's display settings.
User avatar
Zarxrax
 
Joined: 01 Apr 2001
Location: Concord, NC

Re: Bars of color instead of gradients?

Postby Qyot27 » Tue Dec 26, 2006 8:53 pm

dreamoflife02 wrote:ConvertToYV12()
deen("w2d",6,7,9)
Temporalcleaner()
mfrainbow(strength=255)
ConvertToRGB24()

Is the video quality really so abysmal that you need settings that high? (and mfrainbow is known to cause color weirdness - LUTDeRainbow and DFMDeRainbow work a lot better than mfrainbow anyway, IMO)
User avatar
Qyot27
Surreptitious fluffy bunny
 
Joined: 30 Aug 2002
Location: St. Pete, FL
Status: Creepin' between the bullfrogs

Re: Bars of color instead of gradients?

Postby Scintilla » Tue Dec 26, 2006 9:43 pm

Qyot27 wrote:(and mfrainbow is known to cause color weirdness - LUTDeRainbow and DFMDeRainbow work a lot better than mfrainbow anyway, IMO)

... and they can both be found <a href="http://www.aquilinestudios.org/scripts/">here</a>. ^_^
ImageImage
:pizza: :pizza: Image :pizza: :pizza:
User avatar
Scintilla
(for EXTREME)
 
Joined: 31 Mar 2003
Location: New Jersey
Status: Quo

Postby dreamoflife02 » Tue Dec 26, 2006 10:12 pm

Zarxrax wrote:How are you viewing it? In virtualdub? That problem could be caused by virtualdub's display settings.


Ha. I feel silly now. I was viewing it in VDub because nothing else I had would play it... and I just downloaded VLC and it looked fine in that.

Thanks for the suggestion about mfrainbow, Qyot27, I'm pretty new to scripts so I don't know what works best yet.
User avatar
dreamoflife02
 
Joined: 22 Apr 2006

Postby Scintilla » Thu Dec 28, 2006 1:11 am

dreamoflife02 wrote:
Zarxrax wrote:How are you viewing it? In virtualdub? That problem could be caused by virtualdub's display settings.

Ha. I feel silly now. I was viewing it in VDub because nothing else I had would play it... and I just downloaded VLC and it looked fine in that.

For future reference, you can fix this by changing the "Output color depth" under "Quick preview defaults" on the Main tab of the VirtualDubMod 1.5.10 Preferences window (the location may be slightly different for other versions of VDub/Mod); the "Use output setting" setting should do it.
ImageImage
:pizza: :pizza: Image :pizza: :pizza:
User avatar
Scintilla
(for EXTREME)
 
Joined: 31 Mar 2003
Location: New Jersey
Status: Quo


Return to Footage Help

Who is online

Users browsing this forum: No registered users and 1 guest