Can't open AVS files anymore suddenly

This forum is for questions and discussion of all the aspects of handling and cleaning up your footage with Avisynth.
Brakus
Joined: Wed Dec 11, 2002 10:44 pm
Location: Virginia
Contact:
Org Profile

Can't open AVS files anymore suddenly

Postby Brakus » Sat Jun 02, 2012 12:31 am

I'm at the end of my rope here, or so it seems.
For some reason, I can't open any of my AVS files anymore in VirtualDub. I keep getting the error:

Avisynth open failure:
MPEG2Source: couldn't open file
(N:\BASARA\MainMovie\SENGOKU_BASARA_D1\VIDEO_TS\SB1-7.avs, line 1)


After I create the d2v file, I usually open the AVS file that's been created, which simply has 1 line:

Mpeg2source("N:\BASARA\MainMovie\SENGOKU_BASARA_D1\VIDEO_TS\VTS_01_1.d2v",cpu=0)

I've had to install DGIndex manually and made sure I copied the DGDecode.dll file from that installation into the plugin directory. I've rebuilt the d2v file several times and that damn error keeps popping up.

There's got to be some step or two that I've been leaving out somehow. Please help!
~BRAKUS~
Otakon AMV Theater staff, AWA AMV VAT staff
"Whatever you do, enjoy it to the fullest. That is the secret of life."
-- Rider (Iskander), Fate/Zero

User avatar
Cannonaire
Joined: Wed May 05, 2010 5:59 pm
Status: OVERLOAD
Location: Oregon
Org Profile

Re: Can't open AVS files anymore suddenly

Postby Cannonaire » Sat Jun 02, 2012 12:45 am

Try:

Code: Select all

DGDecode_Mpeg2source("N:\BASARA\MainMovie\SENGOKU_BASARA_D1\VIDEO_TS\VTS_01_1.d2v",cpu=0)
Image Think millionaire, but with cannons. || Resident Maaya Sakamoto fan.

Brakus
Joined: Wed Dec 11, 2002 10:44 pm
Location: Virginia
Contact:
Org Profile

Re: Can't open AVS files anymore suddenly

Postby Brakus » Sat Jun 02, 2012 10:29 am

BINGO! That worked. Thanks!
~BRAKUS~
Otakon AMV Theater staff, AWA AMV VAT staff
"Whatever you do, enjoy it to the fullest. That is the secret of life."
-- Rider (Iskander), Fate/Zero

User avatar
Pwolf
Friendly Neighborhood Pwaffle
Joined: Thu May 03, 2001 4:17 pm
Location: Some where in California, I forgot :\
Contact:
Org Profile

Re: Can't open AVS files anymore suddenly

Postby Pwolf » Sun Jun 03, 2012 12:50 pm

Cannonaire wrote:Try:

Code: Select all

DGDecode_Mpeg2source("N:\BASARA\MainMovie\SENGOKU_BASARA_D1\VIDEO_TS\VTS_01_1.d2v",cpu=0)


Is that new in the newer version of dgdecode? Never seen it used that way.
ImageImage
ImageImage
Like the AMV .Org App? Think about donating to help me make it better.

User avatar
LantisEscudo
Joined: Thu Mar 08, 2001 5:21 pm
Location: Vermont
Contact:
Org Profile

Re: Can't open AVS files anymore suddenly

Postby LantisEscudo » Sun Jun 03, 2012 1:40 pm

Pwolf wrote:
Cannonaire wrote:Try:

Code: Select all

DGDecode_Mpeg2source("N:\BASARA\MainMovie\SENGOKU_BASARA_D1\VIDEO_TS\VTS_01_1.d2v",cpu=0)


Is that new in the newer version of dgdecode? Never seen it used that way.


I've seen it before, usually when there's a function name collision with two plugins. The portion before the underscore tells AVS which library to use the specified function from. (mpeg2source is the one I've seen it most often with, between mpeg2dec* and dgdecode both being present so often.)

User avatar
Pwolf
Friendly Neighborhood Pwaffle
Joined: Thu May 03, 2001 4:17 pm
Location: Some where in California, I forgot :\
Contact:
Org Profile

Re: Can't open AVS files anymore suddenly

Postby Pwolf » Sun Jun 03, 2012 1:43 pm

ah, that makes sense.
ImageImage
ImageImage
Like the AMV .Org App? Think about donating to help me make it better.

Mister Hatt
Joined: Tue Dec 25, 2007 8:26 am
Status: better than you
Contact:
Org Profile

Re: Can't open AVS files anymore suddenly

Postby Mister Hatt » Tue Jun 05, 2012 1:00 am

What LantisEscudo said. It's an AVS intrinsic to specify which lib you want to load the function from. It usually happens in dgmpegdec vs mpeg2dec3, multiple versions of vsfilter, and different warpsharp plugins. You can also specify versions. You need to know the internal name of the plugin lib though iirc, not the filename, but that might have changed in 2.5.8 or so.


Return to “AviSynth Help”

Who is online

Users browsing this forum: No registered users and 6 guests