Pixelation when comverting some MKVs to AVI?

This forum is for questions and discussion of all the aspects of handling your footage. If you have questions about capturing/ripping footage, AviSynth, or compression/encoding/converting, look here.

Pixelation when comverting some MKVs to AVI?

Postby mathexpert9981 » Sun Mar 11, 2012 2:19 pm

So I've been making AMVs for a while now, but I've recently run into problems with converting certain MKVs to AVI. On some of these files, there's really bad pixelation, but only when converting it. When I view it in Media Player Classic, the video plays fine, but when I try to convert it, whether using a program converter like Aiseesoft MKV Converter or with AvsPmod/VirtualDub it becomes really pixelated. Here's an example:
Spoiler :
Image

I don't think this is quality loss due to compression, because it's like this before I even compresses it; it's already pixelated on the virtualdub interface when I open it. Here are the specs of the video I'm using (via MediaInfo).
Spoiler :
General
Unique ID : 249438878204956345385202681567857111448 (0xBBA82E342113DAA2B560F0A945A87198)
Complete name : G:\Anime\Nisemonogatari\[Coalgirls-Chihiro]_Hidan_no_Aria_(1280x720_Blu-Ray_FLAC)\[Coalgirls-Chihiro]_Hidan_no_Aria_01_(1280x720_Blu-Ray_FLAC)_[D3BD4882].mkv
Format : Matroska
Format version : Version 2
File size : 540 MiB
Duration : 21mn 10s
Overall bit rate mode : Variable
Overall bit rate : 3 565 Kbps
Movie name : Hidan no Aria 01
Encoded date : UTC 2011-08-30 19:52:02
Writing application : mkvmerge v4.4.0 ('Die Wiederkehr') built on Oct 31 2010 21:52:48
Writing library : libebml v1.0.0 + libmatroska v1.0.0
Attachment : Yes / Yes / Yes / Yes / Yes / Yes

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High 10@L5.0
Format settings, CABAC : Yes
Format settings, ReFrames : 16 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 21mn 10s
Width : 1 280 pixels
Height : 720 pixels
Display aspect ratio : 16:9
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 10 bits
Scan type : Progressive
Title : Hidan no Aria 01
Writing library : x264 core 115 r2008+578 3864dbe
Encoding settings : cabac=1 / ref=16 / deblock=1:1:1 / analyse=0x3:0x133 / me=umh / subme=10 / psy=1 / fade_compensate=0.00 / psy_rd=0.70:0.15 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-3 / threads=6 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / fgo=0 / bframes=8 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=60 / rc=crf / mbtree=1 / crf=16.0 / qcomp=0.60 / qpmin=0 / qpmax=81 / qpstep=4 / ip_ratio=1.40 / aq=1:1.20
Default : Yes
Forced : No

Audio
ID : 2
Format : FLAC
Format/Info : Free Lossless Audio Codec
Codec ID : A_FLAC
Duration : 21mn 10s
Bit rate mode : Variable
Channel(s) : 2 channels
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Title : 2.0 FLAC
Writing library : libFLAC 1.2.1 (UTC 2007-09-17)
Language : Japanese
Default : Yes
Forced : No

Text
ID : 3
Format : ASS
Codec ID : S_TEXT/ASS
Codec ID/Info : Advanced Sub Station Alpha
Compression mode : Lossless
Title : English
Language : English
Default : Yes
Forced : No

Menu
00:00:00.000 : en:Prologue / en:Opening / :Ending
00:02:36.031 : en:Episode
00:20:40.906 : : Preview

I have no idea why some MKVs convert fine and some come out horribly pixelated (and all of them play fine in Media player classic). I'm very noobish when it comes to these things though, so can anybody tell me why this is happening? The codec I'm using is K-Lite Mega pack, by the way. Needless to day, this is becoming really annoying. Thanks in advance! ^^
Image
User avatar
mathexpert9981
 
Joined: 10 Jul 2011

Re: Pixelation when comverting some MKVs to AVI?

Postby mirkosp » Sun Mar 11, 2012 2:37 pm

The video is 10bit. Here's a thread about it that should give you a solution:
viewtopic.php?f=46&t=108096
Image
User avatar
mirkosp
MODkip
 
Joined: 24 Apr 2006
Location: Gallarate (VA), Italy
Status: (」・ワ・)」(⊃・ワ・)⊃

Re: Pixelation when comverting some MKVs to AVI?

Postby mathexpert9981 » Mon Mar 12, 2012 10:06 pm

Thank you so much!! I've been trying to fix this issue for so long, guess I should have posted here in the first place :p.
Image
User avatar
mathexpert9981
 
Joined: 10 Jul 2011


Return to Footage Help

Who is online

Users browsing this forum: No registered users and 4 guests

cron