Problem with MKV and VirtualDubMod

This forum is for questions and discussion of all the aspects of handling your footage. If you have questions about capturing/ripping footage, AviSynth, or compression/encoding/converting, look here.

Problem with MKV and VirtualDubMod

Postby Meteorix007 » Thu Sep 22, 2011 8:02 pm

Hi
Thank you very much for your time.

I have a problem; I have a MKV file with 7.99GB and I want to add an extra audio (another lenguage)
I am using the VirtualDubMod but always crashing with this error:

An out-of-bounds memory access (access violation) occurred in module 'VirtualDubMod'.

Ok, so I started looking for the error in google so I found out that I need a codec and here comes
the problem, I dont know what codec (s) I need.

So far I have tried installing: (all latest version)
-Avisynth
-Xvid
-K Lite Codec Pack
-Divx Total Pack

Nothing seems to work, the crash keeps happening.
I dont know if I have to change the files from somewhere or what but it is really frustrating
since I saw a tutorial in "How To" add extra lenguage to some MKV but so far it has been a real headache.

This is the MKV that I have, I hope someone could tell me what I need to do;
I dont think that my PC can not handle the file, I have a good setting, no ultra but good.

Corei7@3.5Ghz
4GB RAM 1600Mhz
HD-250GB availables
GTX460 1GB

Here, I post an image with the MKV info.

Image
User avatar
Meteorix007
 
Joined: 22 Sep 2011

Re: Problem with MKV and VirtualDubMod

Postby Pwolf » Thu Sep 22, 2011 11:37 pm

ImageImage
ImageImage
Like the AMV .Org App? Think about donating to help me make it better.
User avatar
Pwolf
Friendly Neighborhood Pwaffle
 
Joined: 03 May 2001
Location: Some where in California, I forgot :\

Re: Problem with MKV and VirtualDubMod

Postby Meteorix007 » Fri Sep 23, 2011 1:02 am

It is working, but is just that the audio file that I have extrated with the VirtualDubMod
is in MP3, and with the mediainfo shows duration of 1h 36min, same time as in the MKV
but I have like 1 sec or less behing the audio.

I am playing with the sync, I see that the time it is set in miliseconds so a put -1000
in delay audio option and well I am waiting to see what happens.

The program works great and I wonder if is there a tutorial around to fix sync/audio with mkvmerge
with more info or details about it, I am such a n00b with this things... :oops:

Thank you very much. :)
User avatar
Meteorix007
 
Joined: 22 Sep 2011

Re: Problem with MKV and VirtualDubMod

Postby Zarxrax » Fri Sep 23, 2011 10:19 am

Don't use virtualdubmod. It is VERY old and unsupported, and does not correctly support any of that stuff that you are trying to do.
User avatar
Zarxrax
 
Joined: 01 Apr 2001
Location: Concord, NC

Re: Problem with MKV and VirtualDubMod

Postby Zarxrax » Fri Sep 23, 2011 10:22 am

I forgot to add, use mkvextract to get the mp3 out instead of virtualdubmod.
If that doesnt help, then look at your original file in medinfo, change it to Text View, and see if it displays an offset for the audio file.
User avatar
Zarxrax
 
Joined: 01 Apr 2001
Location: Concord, NC

Re: Problem with MKV and VirtualDubMod

Postby Meteorix007 » Fri Sep 23, 2011 2:31 pm

Yes I will check the mkvextract.

I extracted the audio from a DVDRip, usually the DVDRip comes in AVI not MKV

The MKV is HD-1080p MKV, so once that I extracted the audio from the .AVI in MP3
I just added that audio with mkvmerge and it fits almost exact.

But with the delay of -0700ms it is perfect, at last.

Thank you for your advice and...

to extract the audio from an AVI or MKV file the mkvextract can do the work
or do I have to use some other program to AVI format files ?

And the audio extracted is only in the format that is already in the AVI or may I choose a better/different output like AC3 ?


- thanks : )
User avatar
Meteorix007
 
Joined: 22 Sep 2011

Re: Problem with MKV and VirtualDubMod

Postby Zarxrax » Fri Sep 23, 2011 7:02 pm

Well, for getting an mp3 out of an avi file, i GUESS vdubmod will do ok. There might be some better tool for that though.
User avatar
Zarxrax
 
Joined: 01 Apr 2001
Location: Concord, NC

Re: Problem with MKV and VirtualDubMod

Postby Mister Hatt » Mon Sep 26, 2011 7:48 am

Reformat your entire machine, install mkvtoolnix and CCCP, start over. Your whole setup is a mess and full of old and broken shit, even if you DID get the right software your registry is probably way too fucked for it to work.
Mister Hatt
 
Joined: 25 Dec 2007
Status: better than you


Return to Footage Help

Who is online

Users browsing this forum: No registered users and 2 guests