Fielddeinterlace VirtualDubMod error

This forum is for questions and discussion of all the aspects of handling and cleaning up your footage with Avisynth.
Joined: Fri Sep 04, 2009 2:28 pm
Org Profile

Fielddeinterlace VirtualDubMod error

Postby Jessie-kun » Tue Sep 20, 2011 1:21 pm

So, I'm trying to remove some interlacing from some DVD footage I ripped. I tried using fielddeinterlace(), but when I try and open up the script in VirtualDubMod, I get an error message.

Avisynth open failure: Script error: there is no function named fielddeinterlace

It's been probably a little over a year since I've had to deinterlace footage, and I've forgotten a lot about writing avisynth scripts, so I'm not sure what I'm doing wrong and what I can do to fix it.

Here's my script:

MPEG2Source("C:\Users\Jessie\Documents\Wallflower clips\Wallflower 1.d2v", cpu=4)

Any help would be appreciated. :oops:

User avatar
The Absolute Mudman
Joined: Mon Apr 24, 2006 6:24 am
Status: (」・ワ・)」(⊃・ワ・)⊃
Location: Gallarate (VA), Italy
Org Profile

Re: Fielddeinterlace VirtualDubMod error

Postby mirkosp » Tue Sep 20, 2011 1:28 pm

Uhm... Which guide did you follow? 'Cause that looks like something one would do in 2003 or 2004 tops.
For starters, Read ErMaC & AbsoluteDestiny's Friendly AMV Guides Lovingly Overhauled Largely by Zarxrax. You shouldn't specify the cpu parameter in mpeg2source (if the source really is blocky, use deblock_QED instead, it is better). There are better resizers than bicubicresize (like spline36resize, but you should use resamplehq for proper gamma-aware resizing, though that's another matter altogether), but the fact alone that you're resizing before deinterlacing is bad. And there are better filters to deinterlace anyway, like tdeint. Also, you generally don't want to convert colourspace unless absolutely necessary, so that's the last thing you'd be putting in the script if you really have to do it at all.

Joined: Sat Dec 27, 2008 6:40 pm
Org Profile

Re: Fielddeinterlace VirtualDubMod error

Postby LUCHOO » Thu Sep 22, 2011 7:23 am

Jessie-kun you need "Decomb.dll" filter in the folder "Plugins" of AviSynth ..

Mister Hatt
Joined: Tue Dec 25, 2007 8:26 am
Status: better than you
Org Profile

Re: Fielddeinterlace VirtualDubMod error

Postby Mister Hatt » Mon Sep 26, 2011 7:46 am

I swear every post I see from LUCHOO is full of stupid and backwards. Stop giving bad advice already.

@Jessie-kun read a guide written this decade, then practice. Stop copying avs scripts too, if you cannot write one from scratch AND understand what it does, then don't use avisynth.

Return to “AviSynth Help”

Who is online

Users browsing this forum: No registered users and 1 guest