Avisynth not opening H264 Files

This forum is for questions and discussion of all the aspects of handling your footage. If you have questions about capturing/ripping footage, AviSynth, or compression/encoding/converting, look here.

Avisynth not opening H264 Files

Postby Mastamind » Wed Jul 06, 2011 11:30 am

Welp, I've spent a while pulling my hair out on this one- I performed a system restore on my computer, installed the newest AMVapp, everything like I had before.. When I try to use avisynth to open an H264-encoded file, it gives me an error. I've tried several containers- MKV, MP4, etc, and different scripts (directshowsource, ffmpegsource, ffmpegsource2, ffvideosource..), and avisynth either crashes, tells me it can't open the specified file, or gives me this:

Image

Any help to solve this is greatly appreciated.. Thanks in advance.
Image
User avatar
Mastamind
 
Joined: 09 Sep 2009

Re: Avisynth not opening H264 Files

Postby mirkosp » Wed Jul 06, 2011 11:34 am

You need to include the file's extension too. So for that video it would be:
Code: Select all
ffmpegsource2("C:\Users\richard\Downloads\AtomX&Nessephanie-OurInnocence-720p(x264).mp4")

Also, as a note, if you don't need the audio, you can just use
Code: Select all
ffvideosource("C:\Users\richard\Downloads\AtomX&Nessephanie-OurInnocence-720p(x264).mp4")

as code. You don't need anything extra to use it, it's already in the dll.
Image
User avatar
mirkosp
MODkip
 
Joined: 24 Apr 2006
Location: Gallarate (VA), Italy
Status: (」・ワ・)」(⊃・ワ・)⊃

Re: Avisynth not opening H264 Files

Postby Mastamind » Wed Jul 06, 2011 11:44 am

Derp'd. I didn't write the extension there, but it gave me that error when I did specify it was mp4. :sweat:
And, well, in that time, I installed the newest versions of Haali's media splitter, x264, and ffdshow, and it's.. Working. Thanks anyway.
Image
User avatar
Mastamind
 
Joined: 09 Sep 2009

Re: Avisynth not opening H264 Files

Postby M'o'l » Tue Jul 19, 2011 10:06 am

hey actually my avisynth doesn't do that too and i'm kinda stuck... any mkvs even with mp4 in it work tho :shock:
im using ffms2 with command ffvideosource :uhoh: i have newest haali & cccp
vdub throws at me :File Does not have video stream.
No matter what mp4 i give in script.:<
GO MAGIC CARP USE SPLASH ATTACK.
User avatar
M'o'l
Strawberry Pie
 
Joined: 22 Feb 2007
Location: Sweden
Status: Problem, Officer?

Re: Avisynth not opening H264 Files

Postby mirkosp » Tue Jul 19, 2011 2:23 pm

I'm not sure I understand: mkv files work, but mp4 files don't? In that case, just remux the mp4 to mkv first. Otherwise I'll need more info I guess. :?
Image
User avatar
mirkosp
MODkip
 
Joined: 24 Apr 2006
Location: Gallarate (VA), Italy
Status: (」・ワ・)」(⊃・ワ・)⊃

Re: Avisynth not opening H264 Files

Postby M'o'l » Tue Jul 19, 2011 2:31 pm

Yep, maybe it's indexing problem?

my 64 bit version has the same error btw :P.

newest vdub (but that doesn't matter)

What information would help?
GO MAGIC CARP USE SPLASH ATTACK.
User avatar
M'o'l
Strawberry Pie
 
Joined: 22 Feb 2007
Location: Sweden
Status: Problem, Officer?

Re: Avisynth not opening H264 Files

Postby mirkosp » Tue Jul 19, 2011 7:03 pm

Use everything 32bit or everything 64bit (tip, I'd discourage avs64 for the time being, so make it an everything 32bit). After that, make sure you manually index the video by dragging it on ffmsindex.exe (bigger files can crash if loaded directly before ffms2 makes the cache) and then try to open the ffvideosource("bla.mkv") script. Can't think of much else for the time being...
Image
User avatar
mirkosp
MODkip
 
Joined: 24 Apr 2006
Location: Gallarate (VA), Italy
Status: (」・ワ・)」(⊃・ワ・)⊃

Re: Avisynth not opening H264 Files

Postby M'o'l » Tue Jul 19, 2011 10:56 pm

k, it didn't help, my friend with same problem has a 32 bit setup btw but i will try to clean it up.

just chceked but avisinth(2.5.8)/ffms2 are newest too :<.

i got for experiment r494 ffms2 released 4 days ago
and it doesnt throw anything but there's green screen only in vdub
GO MAGIC CARP USE SPLASH ATTACK.
User avatar
M'o'l
Strawberry Pie
 
Joined: 22 Feb 2007
Location: Sweden
Status: Problem, Officer?

Re: Avisynth not opening H264 Files

Postby mirkosp » Wed Jul 20, 2011 2:55 am

Green screen in the preview shouldn't worry you, it does happen to some people. Try actually transcoding to utvideo and see if that works. Also, do check if it is fine in avspmod.
Image
User avatar
mirkosp
MODkip
 
Joined: 24 Apr 2006
Location: Gallarate (VA), Italy
Status: (」・ワ・)」(⊃・ワ・)⊃

Re: Avisynth not opening H264 Files

Postby M'o'l » Wed Jul 20, 2011 10:02 am

yep changing ffms helped ,btw does the documentaion means internal function audiodub?

because my friends needs audio too and vdub seems to not to catch it
(or avspmod?)
GO MAGIC CARP USE SPLASH ATTACK.
User avatar
M'o'l
Strawberry Pie
 
Joined: 22 Feb 2007
Location: Sweden
Status: Problem, Officer?

Re: Avisynth not opening H264 Files

Postby M'o'l » Wed Jul 20, 2011 10:18 am

nvm i think i figured it out, will it work with 5 channels too?
GO MAGIC CARP USE SPLASH ATTACK.
User avatar
M'o'l
Strawberry Pie
 
Joined: 22 Feb 2007
Location: Sweden
Status: Problem, Officer?

Re: Avisynth not opening H264 Files

Postby mirkosp » Wed Jul 20, 2011 2:29 pm

Yes, multiple channels should be fine depending on the format.
Image
User avatar
mirkosp
MODkip
 
Joined: 24 Apr 2006
Location: Gallarate (VA), Italy
Status: (」・ワ・)」(⊃・ワ・)⊃

Re: Avisynth not opening H264 Files

Postby M'o'l » Thu Jul 21, 2011 11:16 am

kk thanks (:.
GO MAGIC CARP USE SPLASH ATTACK.
User avatar
M'o'l
Strawberry Pie
 
Joined: 22 Feb 2007
Location: Sweden
Status: Problem, Officer?


Return to Footage Help

Who is online

Users browsing this forum: teet and 1 guest