Masking problem in Vegas 6.0

The old Video Software Help forum, left visible as an archive.

Masking problem in Vegas 6.0

Postby Aerialesque » Thu Oct 05, 2006 5:32 pm

First off, I'm not much of a masking genius, since I haven't used the tool much so far in my editing in Vegas (I just switched from WMM a little while ago)...so there could be something I'm missing here.

Here's my issue: I open up the Event Pan/Crop option, use the anchor tool to do my masking frame be frame...no problem there. But then I look at my preview window, and the masks I created in some of the frames aren't lining up to the scene correctly. For instance, I created a mask on one keyframe, and then a different one for the next keyframe, and the preview window showing the previous keyframe's mask on the second keyframe...hopefully, that sort of makes sense. In the Event/Crop tool, each mask looks fine, and perfectly lined up how I want them to be. But when I play the clip on the timeline, some frames look masked correctly, but others are just completely off.

Does anyone know why this is happening? Or what I'm doing wrong? I'm so confused and frustrated...if anyone could help me out, it would be greatly appreciated.
User avatar
Aerialesque
is actually a penguin in boots
 
Joined: 25 Aug 2006
Location: WI

Postby CrackTheSky » Thu Oct 05, 2006 6:25 pm

This has happened to me. I don't know why, and there may be a better way of fixing it than my suggestion, but here's what I think you should do.

First, loop the masked region and render it. Sometimes the preview window can't keep up the clip's FPS (especially when there are a lot of effects and masking on it) so it previews wrong. If you render it into an AVI file and it still doesn't line up right, go into the pan/crop window and move the keyframes in the direction that would "fix" the clip so the masking is correct. For example, if the mask changes too soon, move the mask keyframe to the right in the pan/crop timeline. If this is confusing, let me know and I'll try to explain it better. Then render the clip and see if it's still problematic.

I don't know that it would affect mask syching, but make sure that your anime's FPS is matched up with the FPS you chose when you created a new template in Vegas and started editing the video. This can be viewed and changed in "File > Properties".

If none of this works, the problem may be that your clip is interlaced and your masks are fine, it just *seems* to be off because the interlacing is ruining the flow. I don't think that this is the problem, though, because the interlacing would show up in the pan/crop window.

That's all I can tell you with the information I have, hope it helps!
User avatar
CrackTheSky
Fancy Balls
 
Joined: 27 Aug 2006
Location: Chicago
Status: Probably not editing.

Postby Aerialesque » Thu Oct 05, 2006 8:21 pm

Thanks for the reply! It's relieving to hear that I'm not the only one this has happened to. :O

I rendered that specific masked part, and the problem was still there, unfortunately. I'm not quite sure if I do understand your suggestion completely...correct me if I'm wrong, you're saying just to move the said keyframe a frame over...so...that makes it where the mask isn't lined up correctly in the pan/crop window, but it should look right in the preview, or when I render it again? I tried moving some keyframes, trying to get the masks to line up right, rendered it multiple times, and I still just can't seem to get it to work. -_- It just boggles my mind that the masking looks correct in the pan/crop window, but when I render it, it's way off. Let me know if I'm way off base from what you're trying to explain to me.

I also did double check to make sure the FPS of the anime matched my problem settings, and they are correct.

I also noticed that frames that the masks are off are all keyframes...the rest of the frames are lined up perfectly in the preview, but the keyframes or not...which doesn't makes sense to me, at all.
User avatar
Aerialesque
is actually a penguin in boots
 
Joined: 25 Aug 2006
Location: WI

Postby CrackTheSky » Thu Oct 05, 2006 8:30 pm

Hmm...you understand my suggestion correctly. I don't know what's wrong. The only other thing I can think for you to do would be to right-click on every keyframe and mess around with the settings. Try putting each keyframe on "Hold"...problems I've had with keyframes and masking have been fixed by doing that before. That, or make sure each one is set to "Linear", which should be the default.

If that doesn't solve your problem... :/

I'll ponder this some more, but let me know if the hold/linear thing works, because the more I think about it, the more it seems like that *should* work. It would help if I knew what your mask looks like, so this is the best I can do.
User avatar
CrackTheSky
Fancy Balls
 
Joined: 27 Aug 2006
Location: Chicago
Status: Probably not editing.

Postby Aerialesque » Thu Oct 05, 2006 8:36 pm

Oh, okay. I've never actually messed with those settings before. Though, somehow mine ended up on 'smooth' instead of 'linear'...not sure how that happened. XP I'll try that out, and see if I can get it fixed. *crosses fingers*

If I still can't get it to work, I'll get some screenshots posted. Thank you for all your help, I appreciate it. :D
User avatar
Aerialesque
is actually a penguin in boots
 
Joined: 25 Aug 2006
Location: WI

Postby Aerialesque » Fri Oct 06, 2006 9:33 pm

Hey, CrackTheSky, I just wanted to let you know that I tried putting the keyframes on 'hold'...the preview was still showing the problem, but I rendered the clip, and it seems to have worked! Thanks again for the help, you're a life saver...I can now get on with my video, haha. ;D
User avatar
Aerialesque
is actually a penguin in boots
 
Joined: 25 Aug 2006
Location: WI

Postby CrackTheSky » Sat Oct 07, 2006 12:16 pm

You're welcome!

:D
User avatar
CrackTheSky
Fancy Balls
 
Joined: 27 Aug 2006
Location: Chicago
Status: Probably not editing.


Return to Video Software Help Archive

Who is online

Users browsing this forum: No registered users and 1 guest