.mkv problems

This forum is for video and audio help and discussion.

.mkv problems

Postby TheMarioProductionz » Sat Jun 23, 2012 10:53 am

Hello everyone,

Today I was searching for a decent answer but I just couldn't find any, so I'd be really grateful for your help. :)
I'm trying to start my new amv project but I'm stuck with this problem that all my episodes are in .mkv format. What I'm trying to do is to cut like 2mins out of episode and convert it to .avi or anything that Adobe After Effects CS4 supports. I've tried Avidemux, but when I try playing rendered video my windows crashes ( :?: :?: :?: ). Also I've tried Virtual Dub and Virtual Dub Mod with Avysinc scripts, but I get this message Image ...

If you know how to fix my problem or another way to import .mkv to adobe after effects cs4, please post it here. :(

Thanks in advance and have a nice day~! :)
TheMarioProductionz
 
Joined: 01 Mar 2012

Re: .mkv problems

Postby CodeZTM » Sat Jun 23, 2012 11:00 am

MKV isn't generally the way to import into software. You'll need to convert it into an AVI format. to do that, you will need to make an Avisynth script and open that script into virtual dub. From there, you can save it to an AVI format that the adobe systems can recognize.

http://www.animemusicvideos.org/guides/ ... rmats.html

The guide above should help you out in that regard.
User avatar
CodeZTM
Spin Me Round
 
Joined: 03 Mar 2006
Location: Arkansas
Status: Flapping Lips

Re: .mkv problems

Postby Mister Hatt » Sat Jun 23, 2012 1:53 pm

It would help if you pasted your avisynth script as the error you have said "this guy be doing it wrong", for what it's worth.
Mister Hatt
 
Joined: 25 Dec 2007
Status: better than you

Re: .mkv problems

Postby Cannonaire » Sat Jun 23, 2012 11:49 pm

CodeZTM wrote:MKV isn't generally the way to import into software. You'll need to convert it into an AVI format.

It looks like that is what TheMarioProductionz is trying to do.

Please post your script, then we can help you out.
Image Think millionaire, but with cannons. || Resident Maaya Sakamoto fan.
User avatar
Cannonaire
 
Joined: 05 May 2010
Location: Oregon
Status: OVERLOAD

Re: .mkv problems

Postby Phantasmagoriat » Sun Jun 24, 2012 3:27 am

Drag-and-drop your .mkv into AvsPmod.

That way, you can't screw up the script syntax since it does it all for you.

Then follow the rest of the steps:
http://amvguide.blogspot.ca/2011/07/0-b ... begin.html
Image
Org Profile | AMVGuide | Phan Picks! | THE424SHOW | YouTube | "Galactic Escape"

"Effort to Understand; Effort to be Understood; to See through Different Eyes."
User avatar
Phantasmagoriat
 
Joined: 06 Feb 2006
Status: ☁SteamPunked≈☂

Re: .mkv problems

Postby DaNewbieDatDonRage » Wed Jun 27, 2012 8:35 pm

Phantasmagoriat wrote:Drag-and-drop your .mkv into AvsPmod.

That way, you can't screw up the script syntax since it does it all for you.

Then follow the rest of the steps:
http://amvguide.blogspot.ca/2011/07/0-b ... begin.html


I have a problem with my mkv files as well. I followed all of your steps (installl everything, dropped mkv in AvsPmod, opened with VirtualDub and save it to avi) and when i opened the avi file with Sony Vegas 10 and this showed up:

Image
DaNewbieDatDonRage
 
Joined: 27 Jun 2012

Re: .mkv problems

Postby Phantasmagoriat » Thu Jun 28, 2012 4:12 pm

Umm, since your situation might be different from TheMarioProductionz, you probably should have started your own thread DaNewbieDatDonRage. But I'll try to help anyways.

Yet, I can't read thumbnail-sized pictures so... :sweat:

----------------

On a semi-related note: install or reinstall CCCP

Now if I understand you correctly, you have succeeded in converting it to an .avi file?

What codec did you use? (UTVideo, Lagarith, HuffYUV...)
How big is the file?
Can you open the .avi file in virtualdub successfully?
Image
Org Profile | AMVGuide | Phan Picks! | THE424SHOW | YouTube | "Galactic Escape"

"Effort to Understand; Effort to be Understood; to See through Different Eyes."
User avatar
Phantasmagoriat
 
Joined: 06 Feb 2006
Status: ☁SteamPunked≈☂

Re: .mkv problems

Postby DaNewbieDatDonRage » Thu Jun 28, 2012 4:33 pm

Phantasmagoriat wrote:Umm, since your situation might be different from TheMarioProductionz, you probably should have started your own thread DaNewbieDatDonRage. But I'll try to help anyways.

Yet, I can't read thumbnail-sized pictures so... :sweat:

----------------

On a semi-related note: install or reinstall CCCP

Now if I understand you correctly, you have succeeded in converting it to an .avi file?

What codec did you use? (UTVideo, Lagarith, HuffYUV...)
How big is the file?
Can you open the .avi file in virtualdub successfully?


Nvm, it works now. I installed the UTvideo 8.2.0 codec and it didnt work, so I just installed the new version UTvideo 11.1.0 codec and it works fine now. Thanks anyway.
DaNewbieDatDonRage
 
Joined: 27 Jun 2012

Re: .mkv problems

Postby Phantasmagoriat » Thu Jun 28, 2012 4:43 pm

Well, what do you know: using the latest codec fixed something. Who would have thought... :dino:

Glad you got it fixed ;P
Image
Org Profile | AMVGuide | Phan Picks! | THE424SHOW | YouTube | "Galactic Escape"

"Effort to Understand; Effort to be Understood; to See through Different Eyes."
User avatar
Phantasmagoriat
 
Joined: 06 Feb 2006
Status: ☁SteamPunked≈☂


Return to Video & Audio Help

Who is online

Users browsing this forum: No registered users and 3 guests